Hello!

Did you know that logged in users can see a lot more content?

Manage settings sets

Added August 6, 2019 by Admin admin

Software version: 
Tekla Structural Designer 2019

Manage settings sets

Manage settings sets

The first time Tekla Structural Designer is run after installation you are required to select a country or region. Based on this selection, Tekla Structural Designer creates an initial settings set (the 'active' set), containing defaults for design codes, units, and sections, and settings for drawings, schedules, and reports.

You can edit the settings in this set and also create new sets, but only one set can be designated the 'active' settings set.

Each new project takes a copy of the 'active' settings set to form its own independent model settings.

Model settings can then be edited as required without affecting the active settings set.

Add a new settings set

  1. On the Home toolbar, click Settings.

    The Settings dialog box opens.

  2. Go to Settings Sets.
  3. Click Add Copy.
  4. In the Settings dialog box , modify the settings for the new settings sets.
  5. Click OK to save the settings to the new settings set.

Import a settings set for a different region

  1. On the Home toolbar, click Settings.

    The Settings dialog box opens.

  2. Go to Settings Sets.
  3. Click Import...
  4. Select the region for which you want to import the settings.
  5. Click OK.

Edit the content of a settings set

  1. On the Home toolbar, click Settings.

    The Settings dialog box opens.

  2. Go to Settings Sets.
  3. Select the settings set you want to edit.
  4. In the Settings dialog box , modify the settings according to your needs. For example:
    • Modify the font used to display results in the Results Viewer.

    • Modify the appearance of reports.

    • Set the units that you want to use, and set the desired precision for the units.

    • Set the design codes that you want.

    • Set default section sizes for each of the member types.

    • Set if confirmations are required for specific actions.

    • Set element references.

    • Modify the appearance of schedules.

    • Modify drawing types and styles.

    • Modify the colors used in 2D and 3D views.

  5. Click OK to save the settings to the selected settings set.

Change the active settings set

  1. On the Home toolbar, click Settings.

    The Settings dialog box opens.

  2. Go to Settings Sets.
  3. Select the settings set required from the drop list.
  4. To make the set a default set for new projects, click >> Active.
  5. Click OK.

Delete a settings set

  1. On the Home toolbar, click Settings.

    The Settings dialog box opens.

  2. Go to Settings Sets.
  3. Select the set you want to delete.
  4. Click Remove.

Load settings from the active settings set to the current project

  1. On the Home toolbar, click Settings.

    The Settings dialog box opens.

  2. Go to Settings Sets.
  3. Ensure that the required settings set is active. If it is not, click >> Active.
  4. Click OK.
  5. Open the dialog that contains the settings to be updated.
    • On the Home tab, clickModel Settings.
    • On the Analyze tab, clickOptions.
    • On the Design tab, clickOptions.
    • On the Draw tab, clickEdit...
  6. Click Load...

    A confirmation dialog appears.

  7. To update the model settings to match the active settings set, click Yes.

Save settings from the current project to the active settings set

  1. On the Home toolbar, click Settings.

    The Settings dialog box opens.

  2. Go to Settings Sets.
  3. Ensure that the settings set is active. If it is not, click >> Active.
  4. Click OK.
  5. Open the dialog that contains the settings to be saved.
    • On the Home tab, clickModel Settings.
    • On the Analyze tab, clickOptions.
    • On the Design tab, clickOptions.
    • On the Draw tab, clickEdit...
  6. Click Save...

    A confirmation dialog appears.

  7. To update the active settings set to match the current settings, click Yes.

Copy a settings set from one computer to another

In order to apply consistent settings on a company wide basis, the xml file of the appropriate settings set should be manually copied to other computers.

  1. On the computer containing the settings set, go to the Home tab and clickSettings.

    The Settings dialog box opens.

  2. Go to Settings Sets.
  3. Click Open Folder.
  4. Select the xml file of the settings set, and manually transfer it to the Settings folder on each destination computer.
  5. To view and use the new settings set, restart Tekla Structural Designer on the destination computers.
Content rating: 
No votes yet