Hello!

Did you know that logged in users can see a lot more content?

Tekla Structural Designer 2019i Release Notes

Last updated September 11, 2019 by Tekla Structural Designer Development Team tekla-product-development-tsd-team-ug@trimble.com

Tekla Structural Designer 2019i Release Notes

This release will install Tekla Structural Designer version number 19.1.0.x and should be installed to ensure optimum function of the program. No prior installation of Tekla Structural Designer is required. The release includes a number of significant new features together with several enhancements and issue resolutions as detailed below.

If you are updating from a version earlier than Tekla Structural Designer 2019 SP4 (version 19.0.4.00) you can find details of enhancements and fixes included in all previous releases in Tekla User Assistance (TUA) and Tekla Downloads via the links below:

Licensing & Installation

  • Licensing:
    • New Licenses - No new license is required for this version.
    • License Server - If you have chosen to have a separate licence server, it is always our recommendation that you also run the latest version of the Tekla Structural License Service on it to ensure compatibility. Please see System Requirements for specific version details.
  • Installation - no previous installation of Structural Designer is required. To aid with transition, this release will install alongside existing versions and does not overwrite them.
    • Integration
      • Tekla Portal Frame and Connection Designer - if you wish to integrate Tekla Structural Designer 2019i with Tekla Portal Frame Designer and/or Tekla Connection Designer it is highly recommended you install Tekla Portal Frame Designer 19i and/or Tekla Connection Designer 19i available from Tekla Download Service.
      • Tekla Tedds - if you wish to integrate Tekla Structural Designer 2019i with Tedds for Timber/Wood design you MUST install Tekla Tedds 2019 available from Tekla Download Service.
    • Previous Versions and file compatibility - files from all previous versions can be opened in Tekla Structural Designer 2019i however note that, once saved, they cannot then be opened in an older version. If you wish to retain this option we therefore recommend using the File > Save As… option to save a new version of the file in Tekla Structural Designer 2019i and retain the original.
    • Databases - in this release Material, Section and Reinforcement databases are updated. A message that new databases are available will be displayed in the Process Window as shown below when this release is installed and run for the first time.

    • Please ensure you upgrade your local section databases as follows;
      • Open “Materials” from the Home Ribbon, select the “Sections” page in the list of options, click the “Upgrade” button, then click this button again in the subsequent “Upgrade Database” dialog. Repeat this process for all the other databases (Material, Reinforcement...etc ) to ensure all your databases are up to date.

Highlights

We deliver enhancements in Service Packs as well as the main releases.  We are aware that many Tekla Structural Designer users do not install the service packs and so, for completeness, enhancements in 2019 Service Packs are also included in the lists below. Therefore, this list represents highlights of everything delivered in the last 6 months since the initial release of Tekla Structural Designer 2019 in March this year.

  • General & Modeling
    • New/ Updated Databases & Settings Sets: Nordic Countries, Ireland, Indonesia, Philippines and Thailand
    • Sub Structures Enhancements - Easier Creation and Editing
    • Slab Modeling Enhancements - Move slab items to existing or new Slab Group
    • Selection Enhancements - Selection of individual continuous column and beam stacks/ spans
    • Concrete Cores - Improved Creation, Review and Editing
    • Ghosted Structure View - Improved viewing of model parts such as Sub Structures and Sub Models
  • Loading
    • Seismic Wizard - Response Spectrum Analysis - User-Defined Spectrum by data points - ASCE7
    • Improved Load Decomposition on Roof, Wind Wall and Slab Panels
  • Analysis & Results
    • Concrete Wall and Slab 2D Stresses
    • Results View - Improved Controls for Reactions
  • Design
    • Floor Vibration Check - US Head Code - Updated to DG11 2nd Edition (2016) and Enhanced
    • General Design - User Defined Utilization Ratio - Indian Head Code
    • Seismic Design Enhancements - Steel & Concrete Columns and Beams In SFRS For Two Directions - Indian Head Code
    • Concrete Design - High Strength Concrete - Eurocode
    • Steel Design - Natural Frequency Check - Non-composite Beams - BS, Eurocode, US Headcodes
    • Steel Design - Review View > Show/Alter State Graphical Restraint Settings - All Head Codes
    • Concrete Design - Enhanced Additional Design Forces for Columns, Walls and Result Lines - All Head Codes
    • Concrete Design - Result Line Section Design - All Head Codes
    • Steel Design - Auto-Design Max Span/Depth Ratio - All Head Codes
  • BIM Integration
    • Enhanced ADAPT Export
    • Revit Integration - Revit 2020 Integrator and Interoperability Improvements
  • Output
    • Reporting Enhancements - Analysis and Design Tabular Data Export to Excel
    • Enhanced Pile Design Report Table including pile loads in Tabular Data and Foundation Drawing
  • Performance
    • Reduced RAM Usage and New Faster Operation Option

General & Modeling

New/ Updated Databases & Settings Sets: Nordic Countries, Ireland, Indonesia, Philippines and Thailand (new in this Release)

Reflecting the expanding global use of Structural Designer, to facilitate design in specific countries and regions new and updated Databases and Settings Sets are added as follows.

Database Countries Expanded & New Nordic Country-specific data

As illustrated below, new Countries are added for Steel sections and Reinforcement for; Indonesia, Philippines and Thailand and the Nordic Countries of Finland, Norway and Sweden.

  • For Norway & Sweden:
    • Database:
      • Steel sections are named according to country convention.
      • Steel section order lists contain only commonly available sections for each country.
      • Sections available for selection under each country are only commonly available ones.
    • Settings:
      • Section defaults are ones that are commonly available in the selected country.
      • Steel section Order file defaults are those for the selected country.
  • For Finland
    • Database:
      • New Finland Country is added.
      • Sections available under Finland are the same as the Europe country.
      • Steel section Order lists have been added for Finland and are the same as Europe country.
    • Settings:
      • Section defaults are set to Finland
      • Steel section Order list defaults are set to Finland

New Settings Sets - Ireland, Indonesia, Philippines and Thailand

New Settings sets are added for these countries which can be imported via Home > Settings > Settings Sets as illustrated in the picture below.

  • Ireland - for this Settings set:
    • The Head Code is set to Ireland (Eurocode)
    • Country-specific properties for reinforcement Grade and size are added to the reinforcement database and the Reinforcement Country is set to Ireland.
    • All other settings are identical to the UK
  • Indonesia, Philippines and Thailand - for these countries:
    • Head Code is set to United States (ACI/AISC)
    • Country-specific properties for reinforcement Grade and size are added to the reinforcement database and the Reinforcement country is set appropriate to the selected Settings set.  In addition Concrete Design Settings defaults for Rebar size and spacing, plus other settings, are configured to local preferences.
    • For Indonesia and the Philippines, Rebar detailing prefix for drawings is set to “ø”
    • For Thailand:
      • Rebar detailing prefix for drawings set to “DB” (deformed), “RB” (plain)
      • Section Defaults are set to sections from the Thailand Steel Database.
      • Two additional country-specific metric units of kilogram-force (kgf) and tonne-force (tf) are added and the default units are re-configured to use these.

Sub Structures Enhancements - Easier Creation and Editing (first released in 2019 SP3)

Sub Structures are saved user-defined selection groups of any objects which can be of any size and mix of object types, materials etc.  They can be viewed in isolation and used as filters for many areas of program operation.  Using Sub Structures has multiple productivity benefits throughout the Structural Designer workflow, from model organization and editing through to results review, design and output.   Their creation, review and editing is now made even easier.  For illustration see this video Sub Structure enhancements:

  • Sub Structures and Sub Structure Groups can now be both created and edited via the Structure Tree context menu:
    • The main Sub Structures or Sub Structure Groups folder are now always visible even when no Sub Structures have been created.  New Tooltips for these explain what  Sub Structures are.  Right-click on either of these to access the Create option, or right-click on an existing Sub Structure or Group for the Edit option.  In both cases the view then switches automatically to the Review View in the Sub Structure Review/Update mode, which now uses the Ghosted Structure view to display the objects not in the Sub Structure.
    • An option to Rename a selected Sub Structure is also added to the context menu.

  • Sub structures can also be created and edited directly from the scene; simply make a graphical selection of objects then select the new Add To Sub Structure… command from the scene context menu (right-click to open this).  An additional dialog then opens listing any Existing Sub Structures as shown in the picture below.  You can choose to add the current selection to one of these, or create a new Sub Structure.  Additionally, all selected objects are listed on the left of the dialog with on/off check boxes, allowing further filtering of the selection.
  • When in a View of a Sub Structure, the scene context menu also includes a Remove from Sub Structure option applicable to the current selection in the view.

Slab Modeling Enhancements - Move Slab items to existing or new Slab Group (first released in 2019 SP3)

By popular request, slab items can now easily be moved to another existing slab group or into a new group where the engineer wishes to change the arrangement of slab type/ properties in their model.

  • A new drop-list is added to the Slab general properties which both lists existing slabs and includes a New Slab option - simply select slab item(s) and choose an existing or new group to make the desired edits.

Selection Enhancements - Selection of individual continuous column and beam stacks/ spans (first released in 2019 SP3)

Individual spans of continuous beams and stacks of continuous columns can now be graphically selected, in the same way as individual wall panels in previous versions, both by individual mouse-click and selection window, facilitating more rapid model review and editing.

  • As shown in the picture below, it is now possible to easily select - for review/ edit via the Properties Window - only the stacks in a particular level or levels for multiple columns with a single selection window operation.  The same applies to selection of only specific spans of multiple continuous beams where, for example, you may wish to change the section only for these spans.
    • This behaviour also applies to the tooltip information - this can now be displayed for and individual column stack/ beam span, including when designed the utilization ratio for that stack/span.
    • Note that selection lines and right-to-left windows will still select the entire intersected beam/column.

  • Note that, when entire beams/ columns are selected - by whatever method - the Properties Window drop-down will list them both as single entities - with all general and span/stack properties - and as a collection of multiple spans/stacks - with only span/stack properties.  See the picture below illustrating this.
    • For Steel Column Lifts (length between splices which may contain multiple stacks), it is not possible to edit the section unless all stacks in the lift are selected.
    • It is not possible to delete a single stack/span - delete still deletes the entire member.

  • [TSD-4852] - A further enhancement to selection behaviour is made in this 2019i release following customer feedback;  when a grouped object and all its constituent parts - e.g. a continuous column and all its stacks - is selected for example by a Window selection, it can now be deselected with a single mouse-click while holding down the Keyboard Ctrl key.  Previously this could require several clicks.  This behaviour now applies to all grouped objects; continuous beams and columns, walls and core walls, trusses.

Concrete Cores - Improved Creation, Review and Editing (first released in 2019 SP2)

A number of enhancements are made to the Concrete Cores feature:

  • [TSD-3230] - Assisted Creation - concrete cores can now be created with a single click!  A new ‘Assisted’ creation mode is  added which is active by default and controlled via a new check-box setting in the Core operation Properties window.  When active, all potential members of a core are automatically highlighted when the cursor is moved over any of the constituent members, giving a preview of the core that can be created - a single click then adds all the highlighted walls to a new core (the feature is not active in Modify mode).
    • The Assisted method detects overlapping concrete wall, columns and coupling beams*  that may potentially form a core.
      • *Beams for which the Construction property is set = “Coupling Beam”.   Note that no additional design checks are performed for this construction type so currently it serves only to mark beams; for consideration by the new Assisted core function; for which additional design checks beyond those currently made in the program may be required.

  • [TSD-3203, 3162] - Structure Tree -  powerful additional functionality is added to the context menu options for the Structure Tree Core entries as shown below: new geometry and solver model views for an individual core can now be opened via the menu; edit mode can be activated; the members of the selected core can be both designed and checked via the menu.

Ghosted Structure View - Improved viewing of model parts such as Sub Structures and Sub Models (first released in 2019 SP2)

[TSD-3596] - To improve modeling and review efficiency, the engineer can now enable a “Ghosted” view of the entire model while viewing Sub Structures and Sub Models*, allowing these to be seen in the context of the whole structure.   The view is turned On/Off via a simple [G] toggle button at the bottom right of the view, and the colour and opacity of the ghosted structure can be controlled via new Scene settings as shown in the picture below.   For more see the video on the new feature - Ghosted Structure View.

  • *Although potentially of less utility, the feature is also available for Levels, Frames and Slopes.

Loading

Seismic Wizard - Response Spectrum Analysis - User-Defined Spectrum by Data Points - ASCE7 (new in this Release)

[TSD-3125] The RSA Spectrum curve can now be defined by a set of data points, in addition to the existing fully automated code generated option and manual entry of code spectral curve change points.  This is particularly useful for areas which use the US ASCE7 Loading code with their own locally generated response spectra data.  It may also be useful for other applications which require a fully user-defined spectrum.

  • The option is available for all of; ASCE7-05, ASCE7-10 & ASCE7-16.
  • To use the feature select the new option “Site Specific Spectra (user defined – generic curve)” as shown in the picture below.
    • The curve data can be conveniently pasted directly into the dialog from for example a spreadsheet.  Note that data must be in the form of period vs acceleration values and in ascending order of period (the input dialog features an automatic Sort command if the latter is not the case).
  • Once the curve is defined, the rest of the Seismic Wizard process is the same as the other options, other than the analysis method being fixed to RSA (the generic curve option is not available for the ELF method).
    • The Generic Curve is detailed in the  “Seismic Loading Summary” report, together with all other relevant results.

Load Decomposition Enhancements - Roof, Wind Wall and Slab Panels  (first released in 2019 SP2)

[TSD-1190 & 3976] - the Automatic load decomposition process and settings for the circumstance of Roof panels overlapping slab items is significantly improved, rendering the program workflow simpler and removing a number of limitations.  This applies especially to Wind and Snow loading, both from the associated Wizards and when manually applied.  One-way panels can also now span onto the edges of two-way slab panels.  These improvements also allow the application of area loads via Wind Walls to concrete walls with openings - which previously caused a validation error - again either via the Wind Wizard or manually applied.

  • Where Roof panels overlap slab items, all loads applied to the roof panel are now automatically decomposed by the underlying slab item following its decomposition method, e.g. where the underlying slab is two-way, all loads are now decomposed by the slab in a two-way manner.
    • Thus roof loads - of any type and origin - can now be decomposed in a two-way manner where previously this was not possible.
    • This applies to all loads with the exception of slab and level loads which, as previously, only apply to slab areas.
  • This enhancement removes the Slab/roof overlap validation error for this circumstance and renders the previous Roof panel setting “Decompose only wind & snow” redundant, hence this setting is now removed from roof panel properties.

  • Roof panels and one-way slabs can now span onto the edges of two-way spanning slabs, removing another potential validation error.
  • Load decomposition can now automatically cater for multiple decomposition methods for a single roof panel item, as dictated by the underlying slab items as shown below.

    • With this new functionally, the engineer may question why the Roof panel object is retained, as it would seem to make it redundant.  However, there is still a need to define a roof area as a single object separately from slab items.  For example, as shown in the picture above, a number of separate slab panels may be required within the overall roof area for design purposes - allowing the engineer to specify different amounts of reinforcement and/ or use different slab depths for different parts.  Also some parts of the roof area - e.g. roof-lights or canopies - may have no slab.  However the dimensions of the entire roof area are required by the Wind & Snow Wizards, both for load calculation and application, hence Roof panels are required and retained for this purpose.
  • Wind Wall panels set to decompose to Nodes and Members can now overlap meshed concrete walls with openings, which circumstance would cause a validation error in previous releases.  For decomposition to Members, area Loads applied to the wall panel (not directly to the concrete wall panel) - both manually and via the Wind Wizard - are now decomposed as shown below:
    • Opening areas decompose one-way to the edges of the openings and adjacent areas (where there is no concrete wall panel) to the wall edges per the wind wall span direction. 
    • The load over the concrete wall panel’s solid area is decomposed directly to the wall 2D element mesh and so is effectively decomposed in a two-way manner.

  • [TSD-4128] - Area loads applied directly to Walls with Openings - the area load is now cut back around the opening, as shown in the picture below, and its area excluded from the Load Summary checks.  In previous releases the load would be displayed graphically within the opening and the decomposable loads calculated on the same basis would consequently be greater than reactions (which correctly deducted the load in the openings).  This imbalance would show up as an error in the Project Workspace Loading tree (first released in 2019 SP3) .
    • Note that if you wish the opening area(s) to be loaded, place a Wind wall over the concrete wall(s) and instead apply the area load to this NOT to the concrete wall as described above.

Analysis & Results

New Concrete Wall and Slab 2D Stresses (first released in 2019 SP1)

[TSD-822] - The engineer can now view the stresses on the outer faces of 2D elements.  These are available for both concrete slabs and walls and are added to the options for 2D Results as shown in the picture below.

  • The new results give in-plane axial and shear stress values - calculated directly from the 2D forces and moments - for the top and bottom surfaces.  From these, additional maximum tension/ compression stress values are also derived and listed for display and these can be viewed for envelopes of cases/combinations. 
  • For engineers wanting to consider tensile stresses in walls, the “𝜎y max tension” option will be of greatest interest.  This can be compared to the concrete tensile strength to assess cracking for example.
  • The terms and calculation method for the stresses is fully explained in the Help Topic Stresses in 2D elements

Results View - Improved Controls for Reactions (first released in 2019 SP1)

[TSD-2771] - The Results Ribbon > Reactions options are now rationalized and improved, allowing separate control of reaction display for different elements/ objects.

  • New “1D”, “2D” and “C” buttons turn on/off respectively reactions for; 1D elements (e.g. column support reactions), 2D elements (individual meshed wall supports and mat foundation supports) and Concrete Cores, as shown in the picture below.
    • These can all be activated simultaneously but, in the case of the core “C” reactions being active, any 1D or 2D element reactions resulting exclusively from core members are removed from view.
  • Prior to this there was a single ‘master’ “Supports” control, which turned on/off all reactions, and a “Cores” control which toggled reactions between single core values and those of individual meshed wall supports.

  • [TSD-3165] - 2D Integrated Results - when Core Lines results are selected in the Results View, the rendered shape of concrete columns is now hidden automatically making the core result diagrams clearer (first released in 2019 SP2).
  • [TSD-2771] - Reactions - the label of the button for core reactions is now changed from “C” to an icon of a core in the Results ribbon as shown below (first released in 2019 SP1).

Design

Floor Vibration Check - US Head Code - Updated to DG11 2nd Edition (2016) and Enhanced (new in this Release)

The comprehensive Floor Vibration Check is fully updated to DG11 2nd Edition (2016) of the guide and a new Sensitive use calculations option is added.

  • The Floor Vibration Check to DG11 has been comprehensively reviewed and updated to the 2nd Edition (2016) with revisions and errata of July 2018.  For full details please see the updated Help Engineer’s Handbook for this feature Vibration of floors to DG11.  Please note the following:
    • This replaces the previous check performed to the 1st Edition of the guide.
    • It is possible that high frequency floors deemed acceptable to the 1st Edition may no longer be to the methods of the 2nd Edition.
    • DG11 2nd Edition has a fundamentally different approach for floors classed as High frequency including a new range of classification:
      • There is no direct comparison with the results of the 1st Ed. stiffness method.
      • The High frequency classification range is now 9-15 Hz (formerly >9-10Hz)
      • The engineer is required to exercise more control on inputs; a defined footstep frequency is now required (within range 1.2 - 2.2 Hz); a separate limiting frequency for high frequency floor is required (within range 0.6 - 10 %) - for further guidance refer to Table 6-1 and Figure 2-1 of DG11

  • A new feature is also added in this release for Sensitive use (equipment or occupancy).
    • This is activated by the new Perform sensitive use analysis option in the Floor Vibration Check properties as shown in the picture below.  Please note the following:
      • DG11 2nd Ed outlines methods for one-third octave, waveform peak and narrowband spectral velocities and accelerations.
      • In this first release the calculation is limited to one-third octave analysis and considers the mid-bay position only (worst case).

User Defined Utilization Ratio - Indian Head Code (new in this Release)

In a major design enhancement a User-defined Utilization Ratio (UR) can now be set for auto-design for practically all materials and objects for design to the Indian Design Standards.  This gives the engineer complete control over the level of conservatism they wish to use in their design solution.  The user-defined UR can also be > 1.0 allowing engineers to exercise their judgement on the level of failure that can be allowed e.g "within 5% - OK".  The new setting can be made via element properties and is also added to the Review View Attributes, enabling rapid graphical review, editing and application.    For more, see the new Video on this feature User defined utilization ratio;

  • For complete flexibility the user-defined UR is set on an individual member basis, including individual spans/ stacks of continuous beams/ columns and individual panels of concrete walls.
  • Optionally the UR can also be applied to the calculation check as well as the autodesign process.
  • Note that seismic design checks do not consider user defined UR to perform the check/design.
  • The new setting can be applied to all the following objects:
    • Members; steel and concrete columns and beams, composite beams, steel joists and braces.  This includes separate settings for each span/stack of continuous beams/ columns
    • Steel Trusses - includes; Truss member top/bottom,  Truss member side/internal.
    • Concrete Walls and Slabs including panels, patches, and punching shear checks (note that patches use the same U/R as the parent slab item)
    • Foundations; Pad Bases (Spread Footings), Strip Bases, Pile Caps, Mat and Piled Mat Foundation slabs.

Seismic Design Enhancements - Indian Head Code (new in this Release)

Columns and Beams In Seismic Force Resisting System (SFRS) For Two Directions - IS 800 : 2007 & IS 13920 : 2016

For both steel and concrete materials, columns and beams can now be active in an SFRS in two directions simultaneously (both Dir1 and Dir2).   The SFRS type can be different in each direction, e.g. a steel column can part of a SCBF along the minor axis and SMF along the major axis of column.

  • As shown in the picture below, the Review View > Show/Alter State enables rapid graphical review and/ or application of SFRS type and direction.  The SFRS Type and Direction options are merged into a single SFRS Attribute which includes a “Dir 1 & 2” property for when the member is active in both directions.  Review, Update or Remove modes are available, with the Type and Direction being updated simultaneously and the Legend displaying both type and direction.

  • For beams, the default direction is now set to the direction the beam is modeled when it is first included in an SFRS.  This can subsequently be changed as required.
    • Beams not aligned with the seismic directions are automatically assigned SFRS Directions 1 & 2 and their resolved components of moment capacity are taken about each direction accordingly.
  • There is no change to the scope of the design calculations; checks are made in both directions as required with each considered one at a time - no capacity combination or biaxial checks are made.
  • For steel columns, previously the Seismic checks were not direction specific. Now they are direction dependent i.e. based on SFRS direction of the column and considering the attached beam.  A seismic moment capacity check about minor axis of column is now included where required with a warning.

Concrete Design - High Strength Concrete - Eurocode (new in this Release)

Design for high strength concrete grades is now added for all supported Eurocode National Annexes (NA), expanding the scope of concrete design to very tall/ massive structures for which the use of high strength concrete is more common. 

  • The design applies to all concrete elements; Beams, Columns, Walls, Slabs (including patches and punching checks), Foundations (including punching checks) and composite beams.
  • The Materials Database is updated with six new default normal weight grades:
    • These range from strength class C65/80 > C90/105
      • No new default lightweight grades for high strength have been added as we think it unlikely these would be required - however they can be user-defined if required.
    • Ensure that your local Material database is upgraded to version 30 to add these - see the Installation section above for how to do this.
  • Max cylinder strength - for a user-defined concrete grade this is now capped to 200 MPa where previously the cap was 90 MPa.
    • A Warning is issued  if a strength above 90 MPa is entered as this exceeds the EU recommended value

  • Shear/torsion design - Although the Eurocode itself does not allow NA (National Annex) variation in this area, in various NA documents concerns are suggested regarding shear design using high strength concrete.  For example in the UK NA there is a suggestion that design may be conservatively carried out by assuming a capped strength of C50.  In the Norwegian code the same sort of limit is introduced but is set at 65 MPa for normal weight and 55 MPa for lightweight concrete.  To cater for this, the limiting cylinder strength has been introduced as a user definable value.   The design for all aspects of shear and torsion in concrete elements - including composite beams - is updated to reflect this limit.
    • The limit is defined in a new Design Setting: Design > Settings  > Concrete > General > Limitation on concrete cylinder strength for shear/torsion design, as shown in the picture below.  The default limit values for normal weight/lightweight respectively are set according to the NA as follows:
      • UK, Eire, Singapore Malaysia: 50/50
      • Norway: 65/55
      • EU, Finland, Sweden: 90/90 (no limit stipulated in NA)
      • Note that changing the model Headcode or active Settings set will NOT update these values automatically, hence they should be reviewed by the engineer when doing this.
        • The values will be updated in this circumstance provided you also Load the new active Global Settings via the Design > Settings “Load” command button.

Natural Frequency Check - Non-composite Steel Beams - BS, Eurocode, US Headcodes (new in this Release)

Following customer requests, the scope of the individual beam Natural Frequency Check is expanded to include Non-composite beams.

  • The check can be applied to all single span, simply supported, non-composite beams including rolled, plated and Westoks.
    • The check is not valid currently for beams with web openings (other than Westok Cellular) so should not be used in this case.
    • The check is also now made for Composite beams for the Construction stage.
  • The Natural Frequency check settings are enhanced to give 2-step control as illustrated below (the new settings are also listed in the Properties window for selected beams):
    • A new “Calculate natural frequency” checkbox option controls whether the natural frequency is calculated and reported for a particular beam.
      • Additional settings for the proportion of load to be considered in the calculation are also displayed and can be edited as required.
      • When this setting is checked on the calculated frequency is reported in Design details, including the summary table.
    • An additional checkbox “Check natural frequency against minimum” controls the checking of the calculated frequency against a specified minimum (default = 4.0 Hz) - the entry box for which is only displayed when both settings are checked on.
      • When this setting is checked on the status and details of the check are reported in Design details, including the summary table, as shown below.

Steel Design - Graphical Restraint Settings - All Head Codes (first released in 2019 SP2)

[TSD-357] - In a major productivity update, Restraint settings for steel members can now be quickly and easily graphically reviewed and adjusted via Review View > Show/ Alter State in the same way as other key design settings (previously some of these settings could only be made via the member properties dialog which could be time consuming).   For more details please see the new Help Topic on this feature and this video.

  • Note that the setting terms discussed and illustrated below are for the Eurocode Head Code, however the principles of operation are broadly the same for other Head Codes, with some minor changes to terms e.g. for the US Head Code “LTB” rather than “Lateral” and “Compression” rather than “Strut”.
  • A new Show/ Alter Restraint Attribute is added which applies to the following steel members; Beams, Columns, Truss Top & Bottom Members, Portal Frames.
    • Note that the Lateral and Strut restraint settings are retained in the member properties dialog but do not need to be accessed to use this new feature.  These settings remain the only method for editing the effective length factor, should this be required.
  • When the Restraint attribute is activated, valid restraint locations are automatically highlighted in the view with coloured nodes.   A “Mode” is then selected for the desired operation from; Review (default), Toggle, Set.
    • When in “Set” mode, a specific Restraint Type and configuration can be selected and applied with a single click or box operation.
    • For the Entity types Beams and Top and Bottom Truss Members, the Type and configuration options are;
      • Lateral (relating to Lateral Torsional Buckling and flanges) - Top & Bottom, Top, Bottom, Unrestrained.
      • Strut (relating to compression buckling and lateral fixity) - Minor, Major, Minor & Major, Unrestrained
      • Lateral & Strut Minor - Top & Bottom & Minor, Top & Minor, Bottom & Minor, Unrestrained.
    • The picture below shows the settings for application of Top and Bottom Lateral restraint to beams, and the associated Lateral restraint properties this sets in the beam properties dialog.

  • With the “Continuous” option checked on, the restraint applies to the entire member length/span or sub-beam/ stack which are accordingly highlighted and colour-coded.  Via the Set mode, a selected Restraint Type and configuration can then be applied to an individual member length/span or sub-beam/ stack with a single cursor click, or to a selection of these by drawing a selecting box or line.

  • For the Entity type Column, the column section geometry is automatically displayed and Face A is identified by a member direction arrow drawn on this face.  The following Restraint types and configurations can then be Reviewed, Toggled and Set:
    • Lateral (relating to Lateral Torsional Buckling and flanges) - Face A, Face C, Face A & C, Unrestrained
    • Strut (relating to compression buckling and lateral fixity) - Minor, Major, Minor & Major, Unrestrained.
  • The picture below shows the settings for application of  Lateral restraint to columns, and the associated Lateral restraint properties set in the column properties dialog for a Face A (only) restraint.

  • For Portal Frames the available restraint nodes are: Column top and bottom ends; supported member locations (usually the connecting points of purlins and rails); end of rafter haunch (generated after analysis).  The ‘Continuous’ option is not applicable.
    • Restraint options are (relating to column and rafter flanges and minor axis strut) - Torsional, Outer, Inner, Unrestrained.
      • See the new Help Topic on this feature for more details of the Portal Frame Restraint Settings.
      • Note that there is a shared nodal restraint at the top of the column/end of the rafter.  Any edits made to this restraint apply to the column only (since the end restraint is not editable in the beam properties dialog).

Concrete Design - Enhanced Additional Design Forces for Columns, Walls and Result Lines - All Head Codes (first released in 2019 SP2)

[TSD-3148] - Significant enhancements are made to the Additional Design Cases option in interactive design of concrete Column and Wall design.  The enhancement applies to any column or wall, but is especially useful when investigating Result Line design as described in the section below Concrete Design - Result Line Section Design - All Head Codes.  The picture below shows the changes made to the Interactive Design > Additional Design Cases page compared to the previous release.  For more please see this video on the new feature.

  • New options offer three potential “Design Moment” adjustments for each direction:
    • Set an imperfection eccentricity allowance (Eurocode only).  This is added to the analysis moment.
    • Apply an amplification factor to allow for Second Order Effects (could also be considered as a way to introduce an extra factor of safety)
    • Apply a minimum moment check in one or both directions (the calculation of this is specific to the Head Code set and is a function of the section dimension “h” in the direction considered).
  • When applied, the resulting adjusted design moment is automatically calculated and displayed in the dialog.
  • Informative Tooltips are added for the new columns - just move the cursor over the column header to see these.

  • The adjustment values and options can be applied to individual Cases and also quickly in a single operation to all Active cases (those with “Active” option checked on) via the [Design Moment Factors…] button as shown below.

Concrete Design - Result Line Section Design - All Head Codes (first released in 2019 SP1)

[TSD-2465] - Building on the new 2D Integrated Result Lines feature implemented in the first release of Structural Designer 2019 (v19.0.0.104 released March 2019 - see the Tekla Structural Designer 2019 release notes for more on this), a simple link to interactive wall/ column section design is now added for these.  This will enable the engineer to assess design solutions for Result lines around openings in concrete walls for example, and is available for all Head Codes which feature Reinforced Concrete Design.

  • The Interactive Design option is available from the right-click context menu for Result Lines as shown in the picture below.  The engineer then chooses from  wall or column section design options and the appropriate Interactive section design dialog is then displayed.
  • The wall length/ column depth considered is the Result Line length.  The design dialog features full interactive manual selection of both lateral and vertical reinforcement,  Interaction Diagrams and auto-design and check options, just as for a regular wall/ column section.  Note that result lines are not constrained to cross sections in the horizontal plane - vertical sections can be used above/between openings to investigate forces and reinforcement requirements in “coupling beams”.
    • The section design always considers the main bars (running perpendicular to the cross section) as being on the inner layer, from a design perspective this will tend to be conservative but the engineer should give this some consideration when working with non-horizontal sections.
  • Note that the design does not consider the reinforcement specified in wall properties - only that which is defined in the Interactive design dialog.
  • Currently the feature is not linked with Reports and so it is envisaged output will be via screenshots of the interactive design and check results dialogs.
  • Please see the new Help Topic Manage, display and design result lines for more details on this feature.

 

Steel Design - Auto-Design Max Span/Depth Ratio - All Head Codes (first released in 2019 SP1)

[TSD-1249] - In line with customer requests, a new control is added allowing the engineer to specify a Maximum Span/depth ratio to be considered by auto-design.  This can be set via the Properties Window > Size constraints via the new “Apply max span/depth ratio” option.  The new setting can also be reviewed and/ or copied via Review View > Show/Alter State as shown below.  During design, only sections which satisfy the maximum ratio limit will be selected.

  • To activate the limit in the Properties Window, first enter a non-zero ratio value, then check on the “Apply max span/depth ratio” check box.

BIM Integration

Enhanced ADAPT Export (new in this Release)


The BIM Integration > ADAPT Export link now has the following significant enhancements:

  • [TSD-2680] - Steel Material - steel material grades and their properties in the model - such as their density (unit weight), Modulus of elasticity and Shear modulus etc as listed in the Material Database - are now included in the export.
  • [TSD-2589] - Generic Sections - steel sections and their properties in the model are now exported as generic sections.  This expanded feature also allows for the export of irregular concrete column sections.  The export includes database section properties for steel sections and/ or calculated section properties for concrete sections.  Together with the above enhancement, this increases the scope of the export to include steel members (non-rectangular uniform sections).
  • [TSD-3831] - Concrete Wall forces - bringing the export for the walls to the existing level for columns, concrete wall forces are now exported for both meshed and mid-pier walls.  The exported forces are the 2D Integrated Wall Line results which are used in the concrete wall design in Structural Designer.
  • [TSD-2590] - Self-weight loadcase -  the “Self Weight - excluding slabs” and “Slab self weight” Structural Designer load cases are now exported as a single load case mapped to the ADAPT “self-weight” loadcase.
    • The combination factor exported is the largest from all self-weight loadcases in Structural Designer, where they are different.
  • [TSD-2596] - Slab Column drops - the export no longer uses the native drop cap object in ADAPT, allowing for any drop geometry in the Structural Designer model.
  • [TSD-2594] - Line Loads - horizontal line loads on Vertical Elements - such as those resulting from decomposing wind loads horizontally to columns - are now included in the export, the load being transformed to point loads applied at slab levels.

Revit Integration - Revit 2020 Integrator and General Improvements

A number of enhancements and improvements are made to Revit Integration, both in Structural Designer and the Revit Integrator as follows:

  • Autodesk Revit© 2020 is now supported by the Tekla Structural Designer Integrator for Autodesk Revit© 2020 which was released towards the end of June 2019.  For more information on this and a download link see the Release Notes: Tekla Structural Designer Integrator for Autodesk Revit© 2020 (version 6.0)
    • The fixes and enhancements made in this release also apply to the following versions of the Integrator for earlier Revit versions;
      • Tekla Structural Designer Integrator for Autodesk Revit© 2019 SP1 (version 5.01).
      • Tekla Structural Designer Integrator for Autodesk Revit© 2018 SP2 (version 4.02).
      • Tekla Structural Designer Integrator for Autodesk Revit© 2017 SP4 (version 3.04).
  • Fixes and Enhancements include:
    • Enhanced export of Analysis results - provided the Analysis Results option is checked on when exporting models from Structural Designer, more information will be imported into the Revit model:
      • Splice Forces are now included for Steel Columns - as forces on the bottom of the upper lift.
      • Beam End Forces are included for beams of all material types and for Truss Members (not Internals).
      • Brace Forces are included for Truss Internals as well as Braces.
      • The same simple rules are used to determine Maxima & Minima and not coincident forces.
    • The “Finish” UDA is now added on import to Revit.
    • Bracing releases warnings no longer appear unexpectedly.
      • Previously warning messages could be issued when updating an existing Revit model that the releases had been changed for Structural Braces even though no changes had been made in TSD. This has been fixed.
    • General improvements to handling of concrete column shapes:
      • Tekla Family updates for concrete column sections.
      • Concrete columns modelled in Revit would be exported to TSD with a T-section instead of their actual shape, (C-Sections, Pentagon, Hexagon, Octagon, I-Sections). They are now exported with the correct shape.
      • Previously users might see warning messages in the import log file and L-Shaped columns would be created in Revit with an incorrect geometry.
    • Importing beams/ braces into an existing Revit model no longer resets beam-to-beam and brace joins previously set by the user.
    • Note that the above applies fully only when integrating with Structural Designer 2019 first release (v19.0.0.104) and later.

Output

Reporting Enhancements - Analysis and Design Tabular Data Export to Excel (first released in 2019 SP3)

The Export to Excel option has been added to both the Analyze and Review Tabular Data views.  Using this, any of the Tabular Reports in these views can be sent to an Excel spreadsheet, facilitating further processing and easy sharing of model, analysis and design data with other parties.

  • When the tabular report is configured as you require, simply click the new Excel Export button at the right of the ribbon to automatically send it to a new Excel spreadsheet - the resulting data is listed in separate, headed columns and cells just as it appears in Review Data.

Enhanced Pile Design Report Table including pile loads in Tabular Data and Foundation Drawing (first released in 2019 SP3)

[TSD-802, 1459, 3621] - in accordance with customer requests, the reporting of concrete pile results for both piled mats and pile caps is significantly enhanced.  For illustration see this video Pile Reporting Enhancements

  • The Review Data > Design Summary for piles is expanded and enhanced with the following information:
  • Pile X and Y location coordinates, Inclined Yes/No, Governing Combination and Analysis Method, Load Type, Pile Load and capacity.
  • As detailed above, this comprehensive tabular report can now be exported directly to Excel for easy sharing with third parties such as piling contractors.
  • Foundation Layout Drawing - Any/all data from the enhanced tabulated Pile Design Summary can also be added as an automated table to the Foundation Layout Drawing.
  • By default the table includes the following information; Pile Reference, Name, X & Y Location Coordinates, Load and Limit.
  • Additional columns can be added as required via a new control dialog in Drawing Settings > Options > Foundations > Foundation Layout as shown in the picture below.

Performance

New Faster Operation Option (new in this Release) and Reduced RAM Usage (first released in 2019 SP3)

As part of an ongoing development drive, the internal processes involved in analysis and design have been streamlined and optimized in a number of areas in an effort to reduce both time and RAM usage during analysis and design, to yield potentially significant performance improvements.  Overall we believe that, as a result of this work, some  30-50% performance improvements are typical and in some circumstances significantly greater improvements may be observed.

  • [TSD-4584] - New Performance settings are added to optimise analysis and design performance according to the user’s preference and their PC’s capabilities (new in this Release).
    • New global settings of “Conserve memory” and “Favour speed” are added to Home > Settings > Performance as shown below.  The “Conserve memory” option is as per previous release behaviour and is set on by default.

    • Please note that:
      • We recommend the “Favour speed” option is used only on higher specification PC’s with multi-core processors and the recommended amount of RAM.  See the System Requirements page for more details of specification requirements and recommendations.
      • When changing the setting to “Favour speed” Windows may issue a User Account Control (UAC - see Microsoft Document User Account Control for more) permissions prompt when the program is next run - just OK this to continue and make the setting.  You may need to contact your system administrator if your account does not have the required permissions to make this change.
  • [TSD-1682, 1684, 3545] - Analysis & Design time and RAM Usage - both analysis and the combined analysis and design process (run by the Design ribbon “Design…” buttons) may require significant time and occupy a significant amount of computer RAM (“RAM usage”) to both perform all the calculations involved and store their results in memory.  Internal processes are improved in several areas in order to reduce both process time and RAM usage.
    • [TSD-1588] - 1 D Element results - an example of this is the internal processes for the calculation and storage of 1D element results which have been entirely revamped.  In particular it is expected this should reduce file sizes, file save/opening times and peak RAM demand following the analysis and design processes, with associated analysis speed improvements.
  • [TSD-4102] - Interactive design of Concrete walls - a new option to "Suspend Checking" has been added to the Interactive Design dialog, as shown below, so that several edits can be made before re-initiating checks.  When not checked the program continues to operate as before: checks are made after every edit.  For large structures with many combinations this checking takes time which can be frustrating if you want to make several changes.  When checked on, the button highlights in red making it clear checking is now suspended.  All checks are then carried out and results updated for any changes made when the option is unchecked (first released in 2019 SP3).

  • [TSD-4244] - Properties Window - when working with selections of many objects especially in larger models, the speed of populating the Properties Window with the selection data is significantly enhanced to the extent of being almost instant where previously a number of seconds could be required.

Minor Enhancements & Fixes

General & Modeling

A number of additional fixes which are not detailed explicitly here are also made to improve general performance and stability. 
  • [TSD-2631] - Licensing - in this release an issue is fixed issue where an error message  "The model cannot be saved because it exceeds the model size limit for the currently available license" was given.  The problem occurred if more engineers had been allowed to start using TSD than the available number of server licences.  The message was then displayed if no valid licence could be secured at the point of saving the model.
    • The fix for this issue was actually made in the Tekla Structural License Service, an updated version of which with the fix has been available since mid June 2019 for any affected by this issue - for more see Tekla Structural License Service (2.06).  The updated version of the License Service is now installed by this release and so a separate installation of it is no longer required.

Design

General

  • [TSD-4233] - Steel Trusses - All Head Codes - when a steel truss is checked by right clicking on the truss and selecting the 'Check Truss' option, all the truss members are checked and a Design Details dialog is displayed listing these.  As shown in the picture below, this dialog now includes a Summary table listing the key check results for the critical member of the truss.  The critical member is also flagged in the truss member tree with the usual “❢” symbol.

Head Code India

  • Steel Design:
    • [TSD-2892] - Beams - Deflection - a Slab load deflection check can now be applied.  A new property for the Slab load limit is accordingly added in Beam Properties > Deflection Limits.  As with other limits, both span ratio and absolute limit options are available and, when the check option is activated, these are now checked against the slab deflection from analysis.
    • [TSD-3237] - Seismic Check Summary Tables - for beams, columns and braces forming part of a SFRS, the results of seismic checks, such as Seismic Classification and Strength, are now included in the design summary table.

Head Code US

  • [TSD-2707] - Seismic Design - Seismic Drift - when Vibration Analysis is used for the Fundamental Period - hence always for RSA and potentially for ELF - the fundamental period used for the seismic drift checks is no longer limited to Cu×Ta per Clause 12.8.2.  This applies only to ASCE7-10 and ASCE7-16.  In addition, to clarify the process and calculations performed, the following further enhancements are made as illustrated in the pictures below:
    • The governing equation from section 12.8 used to determine Cs for both strength and drift for each direction is now stated in the Seismic Design report.
    • When the the Seismic Wizard is run again after Seismic Design has been performed, the Fundamental Period page now shows the periods determined from the vibration analysis used in the previous run for both Strength (limited to Cu×Ta ) and Drift (not limited).

Footnotes

1 This number is an internal reference number and can be quoted to your local Support Department should further information on an item be required.

Content rating: 
Average page rating: 5 (1 vote)
Refresh page after voting to show updated result.