Hello!

Did you know that logged in users can see a lot more content?

Tekla Structural Designer 2019 Service Pack 2

Last updated May 29, 2019 by Tekla Structural Designer Development Team tekla-product-development-tsd-team-ug@trimble.com

Tekla Structural Designer 2019 Service Pack 2

This release will upgrade your Tekla Structural Designer installation to version number 19.0.2.33 and should be installed to ensure optimum function of the program.   It includes a number of enhancements and issue resolutions as detailed below.

If you are upgrading from a version earlier than the latest release 2019 SP1 (version 19.0.1.20) you can find details of requirements, enhancements and fixes for all previous releases in Tekla User Assistance (TUA) and Tekla Downloads via the links below:

 

Licensing & Installation

  • Licensing:
    • No new license is required for this version.
    • License Server Version - for Server licenses, it is always our recommendation that you are running the latest version of the Tekla Structural License Service on your license server.  Please see System Requirements for specific version details.
  • Installation - this service pack requires Tekla Structural Designer 2019 to be installed.
    • Previous Versions and file compatibility - Files from all previous versions can be opened in this release however note that, once saved, they may not open in an older version.  If you wish to retain this option we therefore recommend using the File > Save As… option to save a new version of the file and retain the original.

Issues with Associated Bulletins

  • [TSD-1808]1 - Isolated Foundations - Eurocode and BS Head Codes - Punching Shear - for column punching shear checks the perimeter length of loaded areas  was not always the shortest possible.   The issue would only occur for base/ cap geometries which placed the column loaded area at or beyond the foundation edges/ corners.  For more information please see Product Bulletin PBTSD-1905-1.

Highlights

General Modeling

Concrete Cores

A number of enhancements are made to the Concrete Cores feature:

  • [TSD-3230]1 - Assisted Creation - concrete cores can now be created with a single click!  A new ‘Assisted’ creation mode is  added which is active by default and controlled via a new check-box setting in the Core operation Properties window.  When active, all potential members of a core are automatically highlighted when the cursor is moved over any of the constituent members, giving a preview of the core that can be created - a single click then adds all the highlighted walls to a new core (the feature is not active in Modify mode).
    • The Assisted method detects overlapping concrete wall, columns and coupling beams*  that may potentially form a core.
      • *Beams for which the Construction property is set = “Coupling Beam”.   Note that no additional design checks are performed for this construction type so currently it serves only to mark beams; for consideration by the new Assisted core function; for which additional design checks beyond those currently made in the program may be required.

  • [TSD-3203, 3162]1 - Structure Tree -  powerful additional functionality is added to the context menu options for the Structure Tree Core entries as shown below: new geometry and solver model views for an individual core can now be opened via the menu; edit mode can be activated; the selected core can be both designed and checked via the menu.

  • Cores Results in Results View:
    • [TSD-3165]1 - 2D Integrated Results - when Core Lines results are selected in the Results View, the rendered shape of concrete columns is now hidden automatically making the core result diagrams clearer.
    • [TSD-2771]1 - Reactions - the label of the button for core reactions is now changed from “C” to an icon of a core in the Results ribbon as shown below.

Ghosted Structure View

[TSD-3596]1 - To improve modelling and review efficiency, the engineer can now enable a “Ghosted” view of the entire model while viewing Sub Structures and Sub Models*, allowing these to be seen in the context of the whole structure.   The view is turned On/Off via a simple [G] toggle button at the bottom right of the view, and the colour and opacity of the ghosted structure can be controlled via new Scene settings as shown in the picture below.   For more see the video on this new feature.

  • *Although potentially of less utility, the feature is also available for Levels, Frames and Slopes.

Loading

Load Decomposition Enhancements - Roof, Wind Wall and Slab Panels

[TSD-1190 & 3976]1 - the Automatic load decomposition process and settings for the circumstance of Roof panels overlapping slab items is significantly improved, rendering the program workflow simpler and removing a number of limitations.  This applies especially to Wind and Snow loading, both from the associated Wizards and manually applied.  One-way panels can also span onto the edges of two-way slab panels.  These improvements also allow the application of area loads via Wind Walls to concrete walls with openings - which previously caused a validation error - again either via the Wind Wizard or manually applied.

  • Where Roof panels overlap slab items, all loads applied to the roof panel are now automatically decomposed by the underlying slab item following its decomposition method, e.g. where the underlying slab is two-way, all loads are now decomposed by the slab in a two-way manner.
    • Thus roof loads - of any type and origin - can now be decomposed in a two-way manner where previously this was not possible.
    • This applies to all loads with the exception of slab and level loads which, as previously, only apply to slab areas.
  • This enhancement removes the Slab/roof overlap validation error for this circumstance and renders the previous Roof panel setting “Decompose only wind & snow” redundant, hence this setting is now removed from roof panel properties.

  • Additionally, roof panels and one-way slabs can now span onto the edges of two-way spanning slabs, removing another potential validation error.
  • Load decomposition can now automatically cater for multiple decomposition methods for a single roof panel item, as dictated by the underlying slab items as shown below.

    • With the new functionally, the engineer may question why the Roof panel object is retained, as it would seem to make it redundant.  However, there is still a need to define a roof area as a single object separately from slab items.  For example, as shown in the picture above, a number of separate slab panels may be required within the overall roof area for design purposes - allowing the engineer to specify different amounts of reinforcement and/ or use different slab depths for different parts.  Also some parts of the roof area - e.g. roof-lights or canopies - may have no slab, yet the dimensions of the entire roof area are required by the Wind & Snow Wizards, both for load calculation and application.  Thus Roof panels are required and retained for this purpose.
  • Wind Wall panels set to decompose to Nodes and Members can now overlap meshed concrete walls with openings, which would cause a validation error in previous releases.  For decomposition to Members, area Loads applied to the wall panel (not directly to the concrete wall panel) - both manually and via the Wind Wizard - are now decomposed as shown below:
    • Opening areas decompose one-way to the edges of the openings and adjacent areas (where there is no concrete wall panel) to the wall edges per the wind wall span direction. 
    • The load over the concrete wall panel’s solid area is decomposed directly to the wall 2D element mesh and so is effectively decomposed in a two-way manner.

Design

Steel Design - Graphical Restraint Settings - All Head Codes

[TSD-357]1 - In a major productivity update, Restraint settings for steel members can now be quickly and easily graphically reviewed and adjusted via Review View > Show/ Alter State in the same way as other key design settings (previously some of these settings could only be made via the member properties dialog which could be time consuming).   For more details please see the new  Help Topic on this feature and this Video.

  • Note that the setting terms discussed and illustrated below are for the Eurocode Head Code, however the principles of operation are broadly the same for other Head Codes, with some minor changes to terms e.g. for the US Head Code “LTB” rather than “Lateral” and “Compression” rather than “Strut”.
  • A new Show/ Alter Restraint Attribute is added which applies to the following steel members; Beams, Columns, Truss Top & Bottom Members, Portal Frames.
    • Note that the Lateral and Strut restraint settings are retained in the member properties dialog but do not need to be accessed to use this new feature.  These settings remain the only method for editing the effective length factor, should this be required.
  • When the Restraint attribute is activated, valid restraint locations are automatically highlighted in the view with coloured nodes.   A “Mode” is then selected for the desired operation from; Review (default), Toggle, Set.
    • When in “Set” mode, a specific Restraint Type and configuration can be selected and applied with a single click or box operation.
    • For the Entity types Beams and Top and Bottom Truss Members, the Type and configuration options are;
      • Lateral (relating to Lateral Torsional Buckling and flanges) - Top & Bottom, Top, Bottom, Unrestrained.
      • Strut (relating to compression buckling and lateral fixity) - Minor, Major, Minor & Major, Unrestrained
      • Lateral & Strut Minor - Top & Bottom & Minor, Top & Minor, Bottom & Minor, Unrestrained.
    • The picture below shows the settings for application of Top and Bottom Lateral restraint to beams, and the associated Lateral restraint properties this sets in the beam properties dialog.

  • With the “Continuous” option checked on, the restraint applies to the entire member length/span or sub-beam/ stack which are accordingly highlighted and colour-coded.  Via the Set mode, a selected Restraint Type and configuration can then be applied to an individual member length/span or sub-beam/ stack with a single cursor click, or to a selection of these by drawing a selecting box or line.

  • For the Entity type Column, the column section geometry is automatically displayed and Face A is identified by a member direction arrow drawn on this face.  The following Restraint types and configurations can then be Reviewed, Toggled and Set:
    • Lateral (relating to Lateral Torsional Buckling and flanges) - Face A, Face C, Face A & C, Unrestrained
    • Strut (relating to compression buckling and lateral fixity) - Minor, Major, Minor & Major, Unrestrained.
  • The picture below shows the settings for application of  Lateral restraint to columns, and the associated Lateral restraint properties set in the column properties dialog for a Face A (only) restraint.

  • For Portal Frames the available restraint nodes are: Column top and bottom ends; supported member locations (usually the connecting points of purlins and rails); end of rafter haunch (generated after analysis).  The ‘Continuous’ option is not applicable.
    • Restraint options are (relating to column and rafter flanges and minor axis strut) - Torsional, Outer, Inner, Unrestrained.
      • See the new Help Topic on this feature for more details of the Portal Frame Restraint Settings.
      • Note that there is a shared nodal restraint at the top of the column/end of the rafter.  Any edits made to this restraint apply to the column only (since the end restraint is not editable in the beam properties dialog).

Concrete Design - Enhanced Additional Design Forces - All Head Codes

[TSD-3148]1 - Significant enhancements are made to the Additional Design Cases option in interactive design of concrete Column and Wall design.  The enhancement applies to any column or wall, but is especially useful when investigating Result Line design.  The picture below shows the changes made to the Interactive Design > Additional Design Cases page compared to the previous release.  For more please see this Video on the new feature.

  • New options offer three potential “Design Moment” adjustments for each direction:
    • Set an imperfection eccentricity allowance (Eurocode only).  This is added to the analysis moment.
    • Apply an amplification factor to allow for Second Order Effects (could also be considered as a way to introduce an extra factor of safety)
    • Apply a minimum moment check in one or both directions (the calculation of this is specific to the Head Code set and is a function of the section dimension “h” in the direction considered).
  • When applied, the resulting adjusted design moment is automatically calculated and displayed in the dialog.
  • Informative Tooltips are added for the new columns - just move the cursor over the column header to see these.

  • The adjustment values and options can be applied to individual Cases and also quickly in a single operation to all Active cases (those with “Active” option checked on) via the [Design Moment Factors…] button as shown below.

Fixes & Enhancements

General & Modeling

  • A number of fixes which are not detailed explicitly here are made to improve general performance and stability. 
  • [TSD-3974]1 - Object Creation - DXF Shadow - for most previous releases, snapping to points of the DXF shadow (which can be imported into any 2D plane) was limited to the creation of a few select objects such as grid and construction lines.  This was extended to the Measure operation in Release 2019 SP2 and in this release it is extended further to the creation of the following (mainly structural) objects; members, walls, roofs, supports, portal frames and dimensions .
    • As DXF shadows may contain a large number of lines, some of which may be less precisely placed, we urge caution with the use of this feature. 
    • In general snapping to points during member creation will prioritize existing structural objects in preference to what may be arbitrary points in the shadow.  However more care may be needed to ensure the correct points are selected such that the model connection is as intended.  Note that the shadow can be turned off in the plane’s Properties by unchecking the “Shadow visible” option should this cause problems.
  • [TSD-3814]1 - Licensing & Saving - for Server licensing, when the Modelling license feature was lost - which could result from a slow network response or outage -  larger models could not be saved.   On attempting to save an error message would result “The model exceeds the limits of the Lite version…” which engineers could find confusing.  In this release new functionality is introduced to better cater for this circumstance:
    • The model can now be saved once in this circumstance, with the following message being issued “The license is no longer available, therefore the model will be saved now but you will be unable to save any subsequent changes. We recommend you only continue working after you have opened the license manager, and used the refresh command to reclaim a valid license.”
    • As directed, the engineer can then open the License Manager from within the program (Home > License Manager) to reclaim the license providing their network is functioning normally.
  • [TSD-2146, 2693]1 - Portal Frames - in previous releases, where a beam connected to a portal frame column within the rafter haunch depth, a Solver error would occur which prevented completion of analysis - the error message being "Failed to setup haunch on Span X RH/LH column in PF XXX".   An enhancement is made in this release to allow beams to connect to portal frame columns within the rafter haunch depth, and to allow different haunch lengths on opposite column flanges.  Any unnecessary haunch nodes are removed from the created solver model to minimize the risk of short solver elements.
  • [TSD-3907]1 - Review View - Copy Properties - the Show/Alter State > Copy Properties command did not function correctly for certain properties, principally Steel Section and Grade.  These properties could still be copied via the Section/Material Grade command however.  This issue relates only to Release 2019 (version 19.0.0.104 released March 2019 ) - in which it was introduced - and the  subsequent SP1 and is corrected in this release.

Loading

  • [TSD-3906]1 - Wind Wizard - further improvement is made to the graphical wind direction information displayed during the Wind Wizard operation; for the relevant Head Codes, a compass rose which clearly indicates the direction of North is now displayed as shown in the picture below.  Formerly an arrow was displayed indicating the direction of wind from the North which could be misinterpreted.

Analysis & Results

  • Results View:
    • [TSD-1708]1 - Diagrams - Scale & Animation - when the magnitude of results was very large, the diagram scale no longer responded directly to adjustments via the scale settings sliders - it was necessary to Redraw the view (via the context menu Redraw command) to reflect any scale change.
      • Additionally, in the case of the Deflections diagram, Animation would cease to function and just display a static deflection.  This made detection of the manner and location of excessive deflections - such as those resulting from mechanism - more difficult. 
      • This issue relates only to Release 2018i (version 18.1.0.45 released September 2018 ) - in which it was introduced - and all subsequent releases.  It is corrected in this release such that scale adjustments and deflection animation now work correctly in these circumstances.
    • [TSD-1708]1 - Member Deflections -  a number of enhancements are made to the tooltip information for member deflections:
      • The title “Max Relative Deflections” is added making it clear the deflections are relative (to the member axis) rather than global.
      • In addition to the "overall" deflection, the tooltip now includes "major" and "minor" deflection values which correspond to values in the member load analysis view.  The deflections are also reported as a proportion of span.

  • [TSD-1885]1 - Solver Model - Concrete Columns & Two-way Slabs - new Model settings are added and the automatic creation of the solver model is improved for the circumstance of short column centreline to slab 2D mesh ‘rigid link’ elements.
    • As illustrated in the picture below, for concrete columns connected to a two-way slab, the column perimeter shape is cut out of the slab 2D element mesh.  Stiff analysis ‘rigid link’ elements then connect the column centreline (where the column 1D elements are located) to the 2D mesh nodes.  In some circumstances - for example for L-section columns of certain proportions - very short link elements could result, which could cause validation errors or warnings and analysis solution problems.

    • A new automated process and associated settings are added to move the column centreline a small distance where needed to avoid this issue.  As shown in the picture below, the new settings are accessed via Home > Model Settings > Analysis Model.
      • The new option for when a resulting rigid link length would be less than the short element error limit (default = 10mm/ ½ in) is set on by default.  An additional setting - off by default - limits the length to < the short element warning limit.  The distance column centrelines may be moved can therefore be adjusted by the engineer via the short element error and warning limits (for more information about these limits see the Tekla User Assistance article Why are there limits for 1D element length and 2D element quality? )

Design

General

  • [TSD-2975]1 - Foundations - Wall Strip Bases - All Head Codes - in the bending design of wall strip bases, where previously there could be only one critical segment identified per design combination, there can now be two - one for bottom and one for top reinforcement.  This ensures that where necessary the critical results for each surface are always reflected in the design summary tables and highlighted by showing the respective critical segment calculation details.  The top reinforcement design segment will be reported wherever its status is Fail or Warning, or the area required, moment or ratio are non-zero.

Head Code Eurocode

  • Steel Design:
    • [TSD-3487]1 - Columns - in some circumstances where the eccentricity moment was the maximum and smaller real moments existed about one or both axes, a more onerous combined buckling check could be performed in which the uniform moment factor Cm was set = 1.0.  This could produce an overconservative design status and inconsistent design results for columns with ostensibly the same loading.  This is corrected in this release.
    • [TSD-2865]1 - Beams - Web Openings - in some circumstances for web openings with the same dimensions and design forces, the opening section could be classed differently producing a different overall design result.  This is corrected in this release.

Head Code US

  • [TSD-3769]1 - Steel Design - Beams - Web Openings - checks were incorrectly made for the Construction stage using non-composite properties for web openings for all combinations rather than just the Construction stage combination.  The issue applies only to release 2019 - in which it was introduced - and 2019 SP1, and is corrected in this release. 

Reports & Drawings

  • [TSD-1227]1 - Drawings - Default Layer Styles - in line with customer feedback, the colours and fonts of the setting sets Drawing layer styles are updated to be more in line with those commonly in use producing more acceptable drawings ‘out of the box’ - an example is shown below.
    • For all regions (apart from Singapore*) - the default font has been changed to Calibri for all drawing layers.
    • Drawing layer colours have been updated based on customer feedback received, making them more suitable for cad systems with a black background.
      • *Singapore region only - the default font has been changed to Arial for all drawing layers, but the drawing layer colours are unchanged.

  • Note that the new styles will be active in new installations but are not automatically added to existing installations, since you may have customized your settings and so would not want them to be changed or updated.  If you wish to use the new defaults in an existing installation and for existing models, your settings set(s) can be updated by the following process:
    • If you have made any customizations, we recommend you rename your existing Settings set(s) via the Home Ribbon open Settings > Setting Sets; select the set(s) you wish to rename and click the [Rename] button to do so.  You can then revert to the previous set(s) if you wish.  Then click the [Import…] button to import the new updated settings set(s).
    • To update styles in existing models; open Draw > Settings and click the [Load…] button to load the updated settings into the model.
  • [TSD-307]1 - Reports - Member End Forces - A new Member End Forces report chapter has been introduced to extend the existing functionality for reporting beam end forces to the following characteristics: truss top, bottom, & side members; steel joists; columns and mid pier walls.
    • The existing options for reporting the forces at both ends, or just the higher force from either end, and also for reporting coincident forces have been included for the new member types where appropriate.
    • Previously for multi-span beams, end forces were reported at the extreme ends only - this restriction has been removed so that for continuous members the end forces are now reported for all spans.

Footnotes

1 This number is an internal reference number and can be quoted to your local Support Department should further information on an item be required.

Content rating: 
No votes yet