Hello!

Did you know that logged in users can see a lot more content?

Tekla Structural Designer 2018i Service Pack 1

Last updated December 5, 2018 by Tekla Structural Designer Development Team tekla-product-development-tsd-team-ug@trimble.com

Tekla Structural Designer 2018i Service Pack 1

Update

The installation package has been re-published to fix a few minor issues with the initial release - if you are experiencing any issues please ensure you are running 18.1.1.29 before contacting support.

This release will upgrade your Tekla Structural Designer installation to version number 18.1.1.27 and should be installed to ensure optimum function of the program.   It includes a number of enhancements and issue resolutions as detailed below. 

If you are upgrading from a version earlier than Tekla Structural Designer 2018i (version 18.1.0.45) you can find details of enhancements and fixes included in all previous releases in Tekla User Assistance (TUA) and Tekla Downloads via the links below:

Licensing & Installation

  • Licensing - no new license is required for this version.
  • Installation - this service pack requires Tekla Structural Designer 2018i to be installed and will upgrade this to version 18.1.1.27.
    • Previous Versions and file compatibility - Files from all previous versions can be opened in this release however note that, once saved, they may not open in an older version.  If you wish to retain this option we therefore recommend using the File > Save As… option to save a new version of the file and retain the original.

Issues with Associated Bulletins

  • [TSD-1286]1 - Steel Design - US Head Code - Beams - for HSS sections in Torsion previous versions of TSD only took account of Yielding strength when evaluating torsion with combined forces and therefore may have underestimated the utilisation ratio when Local Buckling was more critical than Yielding.  For more information please see Product Bulletin PBTSD-1810-1.
    • This issue is addressed in this release
  • [TSD-1257]1 - Steel Design - US Head Code - Beams - for sections susceptible to LTB, the amplification factor (applied to the stresses sigma_by and sigma_w) may have been evaluated incorrectly in previous versions.  For more information please see Product Bulletin PBTSD-1810-2.
    • This issue is addressed in this release
  • [TSD-1186]1 - Curved Concrete Beams -  Load Analysis Results -  improvements are made to the Load Analysis results for Curved Concrete Beams with Rigid Zones.  Previously erroneous values could occur, generally at member ends, where Rigid Zones were not being correctly accommodated.  For more information please see Product Bulletin PBTSD-1810-3.
    • This issue is addressed in this release.

Fixes & Enhancements

General & Modeling

A number of fixes are made to improve performance and stability.

  • [TSD-1520]1 - Program Error dialog - enhancements are made to the dialog which is displayed when an error is encountered during program operation:
    • The “Cancel” button is renamed to “Ignore”.
    • To further reinforce that not choosing the Revert/ Start again options and continuing with the model is not recommended, a checkbox is added which must be checked on to enable the “Ignore” button.  This is accompanied by the text “I understand that by clicking Ignore I am continuing with a possibly corrupt model and will not be able to overwrite any saved version of the model.”
  • [TSD-1527]1 - Free Points - the first release of version 2018i (v18.1.0.45) introduced “XYZ Points” which could be defined anywhere in the model by three coordinates - the operation of these remains the same but they are now renamed “Free Points”.
  • [TSD-1520]1 - Scene Content - Slab Patches - comprehensive new controls are added to filter the visibility of slab patches by many criteria such as; Type, Surface ...etc. as shown in the picture below.

  • [TSD-1544]1 - Renumbering - Slab Items - the Renumber command for Slabs ceased to function correctly in release 2018 (v18.0.0.33).  This is corrected in this release.

Loading

  • [TSD-570]1 - Load Cases/ Combinations/ Groups and Envelopes  - Ordering - a new feature is added to both the Loading dialog and the Loading Tree to automatically reorder all of;  Loadcases, Combinations, Load Groups and Envelopes.  Clicking the new “Reorder” button as shown below will open a dedicated Reorder dialog box in which you can either "Autosort" (which groups cases/ combinations/ groups/ envelopes by type) or manually select and move items up/down the list using the “Move Up/ Down” buttons.  Multiple items can be selected for a manual move using the usual Windows commands to select multiple rows in a list; Ctrl+click to select several individual items or Shift+click on two items to select these and all items between them.

  • [TSD-1397]1 - Curved Members - Member Loads - previously loads with an axial direction - either point, moment or torsion loads - were prohibited on curved members and produced a validation error .  Such loads are now allowed.

Analysis & Results

  • [TSD-1321, TSD-1689]1 Analysis Model - Slab Meshing - new "Automatic Merging Distances" Meshing controls are added in Analysis Options which help cater for modelling inaccuracies.  The most common example of such inaccuracies is where a slab edge is intended to align with the face of a column but in fact there is a gap of a few mm (or fractions of an in).   For this circumstance the program always performed some merging (of closely proximate column and slab edges) but with a fixed merge tolerance of 0.5mm.  Hence the previous program operation can be matched by using this value.
    • The default merge tolerance value is now 5mm - from our investigations we have found this is sufficient to eliminate meshing failures in a number of test examples (from customer geometry) while producing a satisfactory mesh.  It is also noted that mesh quality warnings are generally reduced and sometimes eliminated by this default value.
    • Further information on the new settings can be found in the new Help Topic... “Engineer’s Handbooks/ Analysis Handbook/ Diaphragms, concrete slabs, and floor meshing /Slab meshing controls”

  • Results View​ - Graphic​al Results:
    • [TSD-1730]1 - Scene Content - 2D Element Results - previously the 1D and 2D element result display options were inconsistent.  For 1D elements results are switched on/off by choosing members to display in scene content, while the 1D elements section of scene content (all unchecked by default) is a way to add analysis elements to the view - it does not control result visibility.  In contrast, the 2D elements options did not actually display 2D elements - they controlled the visibility of results for these elements.  The following change has been made to make the results display control more consistent:
      • The 2D element filters are removed.
      • The "slab items" item now controls display of results for 2-way slabs that are meshed as load carrying slabs in the analysis (default checked)
      • The "walls" item now controls display of results for walls that are meshed in the analysis (default checked)
      • A new "diaphragms" item controls display of results for semi-rigid diaphragm areas (default unchecked)
      • The net result of the above is that; the default display is unchanged; controls for 1D and 2D element results are more consistent; exposing the results for semi-rigid diaphragms becomes simpler.
    • [TSD-1241]1 - Animation - the Animation of deflections has been enhanced so that different cases, modes, etc can be selected and animation for the new selection will start automatically.
    • [TSD-1301]1 - Results Summary Text - the results summary displayed at the top left of the Results View Scene is improved to include the selected analysis method and case/combination/envelope.  This improves reports where results views have been added using saved view configurations of result diagrams.
    • [TSD-1614]1 - Sway and Drift Result Diagrams - the Results ribbon buttons for Sway Drift and Storey Shear  'Sway X', 'Sway Y', 'Relative Sway X', 'Relative Sway Y' are renamed 'Sway Dir 1', 'Sway Dir 2', 'Relative Sway Dir 1', 'Relative Sway Dir 2'.   This is because the graphical displacement values plotted on the diagram are the resultant of the displacements in the direction, and perpendicular to the direction, of the applied lateral load which itself is always applied in the Building Directions.  These will not correspond with the global X and Y axes when the Building Direction Rotation is <> 0.  Hence the revised names are more appropriate.  Similarly, the buttons 'Wind Drift X' and 'Wind Drift Y' buttons are renamed 'Wind Drift Dir 1' and 'Wind Drift Dir 2' as the the displacement values plotted on the diagrams relate to the building directions.
  • [TSD-1000]1 - Vibration Analysis - Total and Active Masses by node - a new “Simple” Mass reporting option is added to the Vibration Analysis Options (see picture below).  This can be used for example by those wishing to use the Dynamic Mass output (Total and Active Masses by node) to determine a centre of mass or mass moment of inertia for each floor of a model.   When the Simple option is activated, a single value of mass for each node is reported in the Analyse > Tabular Data tables for Total and Active Mass by node.  This also applies to the associated Report items.
    • Note that it is recommended that the new Simple mass option is used only when the Lumped Mass Model is used.

  • [TSD-903]1 - Analyse > Tabular Data - the output tables for items in Analyse > Tabular Data that are listed by node - such as Deflection, Mode Shape and Masses by Node - now include new columns giving the node coordinates.  It is possible to sort the nodes by coordinate, making it easier to examine the results on a floor or diaphragm basis.  The same additional columns giving the node coordinates are also included in the associated Report items.
  • [TSD - 828]1 - Storey Shears - for lateral load cases and combinations of all types, the program has always calculated and output values termed “Storey Shears”.  Depending on the analysis type and application, this term can have different meanings.  For example in Seismic Analysis this term is used for the cumulative shear at each level of a building (which produces the total base shear at the 1st storey), rather than the total shear for a single level (often termed the ‘floor force’).  Accordingly, the output and terminology for these results is enhanced as follows:
    • Two entries are now available in the Review Data > View Type dropdown; “Inter-storey Shear” and “Cumulative Storey Shear”.   The former is the total shear for a single level (AKA ‘floor force’), while the latter is the cumulative shear at a level derived by summing all the inter-storey shears of that level and those above it.
      • For Response Spectrum Analysis (RSA) these can now be viewed for each mode as well as for the Modal Combination (CQC by default).
    • Reports - the associated Report item “Storey Shears” is similarly replaced by two new Report items for “Inter-storey Shear” and “Cumulative Storey Shear”.
      • Note for RSA these are the Equivalent Inter-storey Shears and Combined Cumulative Storey Shears resulting from Modal Combination (individual Modal results are not available in reports)
  • [TSD-1538]1 - Analysis Condition - the list of Analysis Types displayed when cursoring over the Analysis Condition button (on the bottom status bar) did not include entries for 1st and 2nd order RSA Analysis.  These are now added so their status can be reviewed.

Design

General

  • [TSD-500]1 - Slab/ Mat Design - Punching Checks - the scope of slab punching shear check/design has been extended to include instances of non-concrete columns supported on concrete slabs.  Because extending the scope to these members also increases the probability of having loaded areas and member sections of different dimensions - by the use of base plates or pedestals - we have also introduced the option to override the dimensions of the loaded area for slab punching checks in general, which follows upon the functionality already in place for checks under point loads.   An example is shown in the picture below.  This applies to the following Head Codes; Eurocode, US, BS and IS.

  • [TSD-1404]1 - Steel Design - Beams - Imposed Load Reductions (ILR) - Steel beams can now be designed for reduced loading effects in the same manner as was introduced for concrete beams in the first 2018i release.  The level of imposed load reductions to consider can be defined manually in beam properties.  This is especially useful for more economic design of transfer beams supporting a number of floors.   This applies to all Headcodes except the US - for the US headcode the ILR is automatic and already catered for in design.
  • Concrete Design - Interac​tive Design:
    • [TSD-1476]1 - Columns - operation is enhanced as follows for columns in groups (note that this prevents the creation of invalid groups which could occur in previous versions):
      • When the selected column is part of a group and changes are made to section size and the Interactive Design Dialog is OK’d, a choice is now offered to either;  update the entire group with the change (Yes) or update only the selected member and remove it from the group (No).
      • In addition to the above,  the Interactive Design Dialog header now indicates how many members are in the same group as the member currently being edited.

    • [TSD-1476]1 - Columns and Walls - the interaction diagram display is further enhanced so that:
      • The design forces for the selected analysis case and position are displayed.
      • The M-M diagram position is adjusted to improve the default display.
  • [TSD-1464]1 - Connection Resistance Check - the scope of this is expanded to include the Cold formed (Steel) material.  The functionality is the same as existing for the Steel material - resistances can now be added for cold formed sections via Home > Materials > Sections > Connection Resistance and results viewed after design in Review View > Tabular Data.  Connection Resistance Report Items for these are also added.  This applies to the Eurocode and BS Headcodes.
  • [TSD-860]1 - Sway and Drift checks - depending on the Head Code in operation, structure stability can be assessed either by a Drift check (US Head Code) or a Sway check (other Head Codes).  Consequently, when the US code is active, the Sway check results are hidden.  For other head codes the Drift check results should similarly be (but previously were not) hidden - this is now corrected.

Footnotes

1 This number is an internal reference number and can be quoted to your local Support Department should further information on an item be required.

Content rating: 
No votes yet