Hello!

Did you know that logged in users can see a lot more content?

Tekla Structural Designer 2018 Service Pack 1

Last updated May 2, 2018 by Tekla Structural Designer Development Team tekla-product-development-tsd-team-ug@trimble.com

Tekla Structural Designer 2018 Service Pack 1

This release will upgrade your Tekla Structural Designer installation to version number 18.0.1.10 and should be installed to ensure optimum function of the program.   It includes a number of significant new features together with several enhancements and issue resolutions as detailed below.

If you are upgrading from a version earlier than Tekla Structural Designer 2018 (version 18.0.0.32/331) you can find details of enhancements and fixes included in all previous releases in Tekla User Assistance (TUA) and Tekla Downloads.  You will find all the main releases listed here while those for Service Packs can be found by searching TUA using “Service Packs” as the search term.  Links to release notes together with the version number can also be found in Tekla Downloads for TSD here (login required).

Licensing & Installation

  • Licensing - no new license is required for this version.
  • Installation - this service pack requires Tekla Structural Designer 2018 to be installed and will upgrade this to version 18.0.1.10.
    • Previous Versions and file compatibility - Files from all previous versions can be opened in this release however note that once saved they cannot then be opened in an older version.  If you wish to retain this option we therefore recommend using the File > Save As… option to save a new version of the file and retain the original.
  • Section Databases - in this release Section databases include new and updated properties.   A message that a new database is available will be displayed in the Process Window similar to that shown below when this release is installed and run for the first time.
  • Your local section databases should then be upgraded as follows;
    • Open “Materials” from the Home Ribbon, select the “Sections” page in the list of options, click the “Upgrade” button, then click this button again in the subsequent “Upgrade Database” dialog.  Repeat this process for the other databases (Material, Reinforcement...etc ) to ensure all your databases are up to date.

Fixes & Enhancements

General & Modelling

  • Performance and Stability - a number of fixes and enhancements are made to improve general program stability and performance.
  • Tekla Tedds Link - although not a specific new feature of this Service Pack, it is worth mentioning that, providing that Tekla Tedds 2018 is installed, and Tedds Engineering Library (March 2018) update is applied, the new Tekla Structural Designer > Tekla Tedds timber design calculation link can be used to design timber members in a Tekla Structural Designer model (for the Eurocode headcode).  For how to use the link please see the Tekla Structural Designer TUA video Timber design using the Design using Tekla Tedds Export feature.
  • Tekla Connection Designer (TCD) Link - a number of improvements and enhancements are made as detailed below.  Please note that this requires the installation of the Tekla Portal Frame Designer 18 and Tekla Connection Designer 18 Service Pack 1.
    • A new connection type Column Splice is now added.  These are automatically added to all column splice locations in the model when the “Update Connections” process is run, as for other connection types.  For more on integrated connection design please see the Tekla Structural Designer TUA video Tekla Connection Designer Export.  Splice connections can be designed for both the BS and Eurocodes.
      • Note that for the splice tying force robustness check there is a difference between the BS and Eurocodes; the former uses forces from ULS combinations while the latter uses those from Accidental combinations.  Currently Accidental combinations cannot be created manually in TSD.  They are created by the Combination Generator only when a load case of the type “Snow Drift” exists.  Hence to create Accidental combinations it is necessary first to add a load case of the type “Snow Drift” (which does not need to contain loads) then run the Combination Generator and check ON the Accidental combinations option.  For more information on the tying force robustness check see this NSC AD Article.
    • Eurocode - Column Base Connections - a program error would result when attempting to check a connection with uplift loads within TSD  since uplift (a negative column axial load) is beyond scope for the Eurocode (design in TCD is prevented in this circumstance).  When attempting to design for this circumstance within TSD, an error message is now returned in the Process Window within the program, alerting the user to the problem (TSD-76 1).
    • Beam-to-Beam Moment Connection - for this connection type - common for rafter apex connections - the design forces were not correctly populated for one side of the connection (TSD-182 1).
    • While all connection types can be edited directly and checked within TSD, not all of the connection data is currently retained for types other than Base Plate Connections.  In addition there is no reporting for connection design within TSD.  Hence please note the following recommendations:
      • It is always necessary to export all connection types to TCD for reporting purposes.
      • Base Plate connections can be fully edited and designed within TSD.  In addition the TCD function “Return Connection to TSD” (under the “Connection” menu) can be used to return connection data to TSD.
      • For connection types other than Base Plate Connections the recommended workflow is:
        • Select the connection(s) to be designed and export to TCD always.
        • Design in TCD and print the reports.
        • While the “Return Connection to TSD” command can be used, this may not return all connection data to TSD currently.  Hence, if changes are made in TSD and the analysis and/ or design processes run and the connection exported again for checking, the engineer should review the connection data and may need to re-enter some of the settings previously made.
  • BIM Integration:
    • Cellbeam Export - In some circumstances an incorrect error “The top tee is cut from an unsupported section” could occur (14849 1).
    • IFC Export - Concrete Walls - holes in walls were not correctly exported (TSD-57 1).
  • Section Database - the sections database now include the recent changes made in AISC v15.0.  Accordingly the local section database should be updated - see the Installation section above for how to do this (TSD-142)
  • File Saving - Potentially Corrupt Model Files - a new feature was introduced in the first release of 2018 to prevent saving of a file (over the original/ last ‘good’ saved state) when an internal program error was detected which could potentially cause corruption of the file data.  There have been some refinements to this process as follows (TSD-220 1):
    • In this circumstance - when either a Save or Autosave is attempted after an internal program error occurs - a warning message box now displays allowing the user to revert to the original file state before the error by clicking OK (some recent edits may then need to be re-input).
    • Please note that the recommendation is always to choose OK to revert to the original uncorrupted version to ensure minimal loss of work.
    • If the No option is chosen, it will not be possible to save over the the original/ last ‘good’ saved state.  We strongly recommend not to continue trying to work with the potentially corrupted file.  If the engineer wishes, they can at this stage save the potentially corrupted file to a new file name/ location, and then send ‘before’ and ‘after’ versions to their local Support Team for investigation.
      • Any files flagged as potentially corrupt in the first release of 2018 (version 18.0.0.32/33 2) will have the flag removed when they are opened for the first time in this release.
  • Views - Keyboard Shortcuts - a new keyboard shortcut command is added to zoom to a selection.  To use this, make a selection of objects then press the Z and S keyboard keys in turn - the view will automatically zoom to the selected objects.  This works well in conjunction with the already implemented Zoom Out function which has the keyboard shortcut "ZA"
  • Edit - Rationalize - the command did not correctly differentiate between grid and construction lines, thus (unused) grid lines would still be removed when only the Construction Lines option was checked on and the command run (14618 1).
  • Ribbon - Group Names  - a tooltip facility is now added to show the full Group Name where this is curtailed in the Ribbon arrangement - for example on the Results Ribbon where the Group Name “Notional Loads” is curtailed to “Noti”.  The full group name is now revealed when the cursor is moved over the “>” button to the right of the Group Name (54850 1).

Loading

  • Perimeter Loading - a program error would occur when editing perimeter loads on duplicate levels.  This could be worked around by setting the level to be unique prior to making the edit.  This workaround is no longer required (TSD-113 1).

Validation

  • Project Workspace - Structure Tree - improvements are made to validation message behaviour following design checks and model changes:
    • Validation messages are no longer removed after running check design for any member.
    • Validation messages are no longer removed when a change is made to the model which changes the analysis status of the model  - instead a validation warning is issued stating the validation message is out of date. The engineer is then able to see all validation warnings/errors from the previous validation run.
    • When validation is re-run the previous results are wiped and new ones are regenerated for the particular validation that has been carried out.

Analysis & Results

  • Analyse > Tabular Data - Nodal deflections - control buttons similar to those in the Results view are added to display Load Combination deflection values for either Strength or Service factors (13678 1).
  • Rigorous Slab Deflection - Load Event Sequence - Beta Parameter:
    • When cracking occurred in initial events, where the Beta value was set to 1.0, the extent of cracking carried forwards would be increased in later events, leading to a conservative estimate of the long term deflection of the final event.  A less conservative interpretation of the evolution of cracking is introduced  in this release (TSD-62 1).
    • The value of Beta for each event should only reduce over time.  If a Load Event Sequence is defined where the value of beta reduces to 0.5 and then increases to 1 subsequently, a warning is now issued "Value of ? greater than in previous Event. This suggests tension stiffening is recovered." (TSD-145 1).

Design

General

  • Design of Model “Subsets” - when designing or checking model subsets - such as all members in a level or all concrete walls - from the Structure Tree (via the context-menu options), the design summary dialog is no longer displayed at the end of the process.  This has both significantly speeded up the process and reduced the amount of RAM required, making this method of design much more practical especially for larger models with many combinations.  At the completion of the process the view is automatically switched to Review View > Status as at the end of a full Design process (4609 1).
    • Additionally, when designing subsets group design is now carried out in the same way as in the full design process.  If the subset contains any members of a group then the entire group is designed.  This minimises the potential for confusing fail statuses appearing at the end of a sub-set design.
  • It is anticipated that the revised subset design procedures will allow large models to be worked on much more efficiently.
  • Slab Design:
    • Punching checks - in some circumstances, for checks applied to column drop locations, the column drop was not correctly identified and the appropriate punching check setting activated.  This could be worked around as follows; shorten column via the "Top level" property and then extend it back to the original level.  The workaround is no longer required (14900 1).
    • Slab Patches - for beam patches, the property “Cover as Panel” can now be user-controlled to allow a different cover to be entered for the patch reinforcement design, when the "combine with panel reinforcement" setting is off.  Previously this setting was fixed and the cover could not be adjusted when the patch was aligned with the panel reinforcement direction (54178 1).
  • Foundations - Isolated Bases - Sliding - when the “Sliding in X/Y Prevented” property was checked on, a Fail status for the sliding check could still be assigned for pad bases subject to uplift.  A pass status is now correctly assigned in this circumstance (14862 1).
  • Composite Beam Design - Deflection - the calculation of deflections for snow and wind load cases used the bare beam inertia rather than the composite inertia.  While it is unusual for composite beams to resist snow or wind loads there are situations where this is possible - for example transfer beams supporting roof areas - and so this is corrected in this release (54972 1).
  • Gravity Design - Options - the option to “Fix column nodes horizontally” for the analysis portion of the Gravity Design process is now added to the Model settings under Design > Options > General (4475 1).
  • Concrete Beam Design - Interactive Design - Links (Stirrups) - for the design of links for shear and torsion resistance, and where the maximum utilisations for these resulted from different combinations, there was an inconsistency between the Interactive Design dialog and the Design Details; the former could display a failure utilisation while the latter correctly showed a passing status.   This was due to the Interactive Design summary results incorrectly combining the worst case utilisations from different combinations, rather than displaying the required areas and utilisation for the single governing combination using the coincident shear and torsion forces within this only.  Thus the design details results were the correct ones.  The issue is corrected in this release and the Interactive Design dialog and the Design Details results are now consistent (TSD-83 1).

Head Code Australia

  • Concrete Design - Beams - in some circumstances a program error could occur when designing concrete beams preventing the design process from completing (TSD-198 1)

Head Code US

  • Steel Design -  Beams:
    • The correct critical combination results were not always displayed for the combined forces check when the design details summary table entry for this check was expanded (54911).
    • LTB check - where the LTB effective length L_b is less than the limiting unbraced length L_p, calculations beyond those for the evaluation of L_p are no longer reported (54924 1).
    • Web Openings - steel non-composite beams supporting a ‘precast’ type floor slab were incorrectly set to be beyond scope and no design checks were performed.  Design checks are now performed in this circumstance (TSD-43 1).
    • Composite Beams - Torsion  - for beams subject to torsion force and with both the ‘allow non-composite design’ and ‘Check Torsion’ settings on, when non-composite design is triggered the torsion checks are now also performed (TSD-125 1).
  • Concrete Design - Beams - Seismic Design - the calculation of minimum allowed area of flexural reinforcement in beams forming part of a Special Moment Frame is now implemented for ACI 318 2008 (formerly it was only implemented for the 2011 version of ACI 318) (TSD-183 1).
  • Foundations - Pile Caps - the minimum depth to bottom reinforcement in pile caps is now set to 300 mm (12 in) rather than 150 mm (6 in) in accordance with the requirements of ACI 318 (TSD-176 1).

Reports & Drawings

  • Member Detail - Concrete Beams:
    • New End Support Curtailment setting - previously end reinforcement was always extended the full length/width of a supporting beam/column.  In some circumstances this would appear to be an excessive anchorage length on the detail drawing.  The drawing methods and settings are now improved to prevent this:
      • A new Beam Detail setting has been added to control the extension/ application of end bobs within the supporting member.  This is found in Design Options > Concrete > Beam > Detailing Options on the End Support Curtailment tab -  “Extend and bob all bars for supporting member widths up to” with a user-editable value box (Metric default = 1000mm, US customary default = 36”).
      • Where the supporting member width is > entered value, reduced anchorage lengths result (as for anchorage into in-plane walls).
    • Excessive anchorage lengths could result when the reduction factor A_s,reqd / A_s,prov was > 1.  Although this would only occur where the design was failing, the factor is now limited to 1 so that it never increases the anchorage length (55077 1).
  • Model Report - Wind Data - a report including the Wind Data item would fail to generate for any model with Wind Wizard data with BREVe set as the Data Source.  Thus only United Kingdom and Ireland BS or Eurocode Head Code models would be affected.  Since the Wind Data item is included in the standard “Building Loading” report style, this report would consequently fail to generate.  This could be worked around by removing the Wind Data item from the report - however wind data itself could not be output.  This issue is fixed in this release, and relates only to the first release of version 2018 (18.0.0.32/33 2) in which it was introduced (TSD-72 1).
  • Member Reports - Slab Deflection Check Line - initially reports for these would be blank because the “Deflection Checks Summary” item was not included in the Slab Deflection Check Line Member Report by default.  It is now included by default in this release for new models, however note that it will still be necessary to include this item ‘manually’ for existing models (via Reports > Member Report… > Slab Deflection Check Line and dragging the the “Deflection Checks Summary” item into the right hand Report Structure box) (TSD-53 1).

Footnotes

1 This number is an internal reference number and can be quoted to your local Support Department should further information on an item be required.

2 The installation package was re-published on the same day as the initial release to fix a minor issue with the packaged files, hence two versions. Version 18.0.0.33 is only required for Nordic Headcodes.

Content rating: 
No votes yet