Tekla Structural Designer 2016i technical release notes

Last updated November 20, 2017 by Tekla Structural Designer Development Team tekla-product-development-tsd-team-ug@trimble.com

Tekla Structural Designer 2016i technical release notes

This release should be installed to ensure optimum function of the program. Several improvements and issues have been resolved including:

Issues with Associated Bulletins

  • Wind Wizard - Head Code EC - when the Wind Load cases option “Structural Factor - Automatically calculate separate cs and cd factors” is set to On, in some circumstances the automatically calculated Structural Factor cscd is incorrect and significantly lower than it should be producing a reduction in applied wind loads. The issue is fixed in this release. For more information please see Product Bulletin PBTSD-1609-01 (12530).
  • Concrete Beam Design - Head Code US - flanged beams (commonly termed “T-beams” and “L-beams”) with the following Properties both ticked on: Design Control > “Consider flanges” and “Include flanges in analysis”. For these settings, the deflection result directly from analysis included the effects of the flange, however the modified design deflection of the rigorous deflection check did not. This could produce an underestimate of the design deflection and an unconservative result for the deflection check. The issue is fixed in this release. For more information please see Product Bulletin PBTSD-1609-02 (51679).

 

New Features

Major

  • Mat Foundations - a new feature allows the definition and design of foundation slabs. Optional soil springs are automatically calculated and applied to the FE slab’s mesh nodes from the input of a modulus of subgrade reaction. In addition to automatic bearing pressure checks, full auto-design (to EC, BS, ACI & IS design codes), rationalisation and output functionality for foundation slabs matches that already available for flat slabs.
    • Mats can be designed for RSA forces when they contribute to the lateral load resistance system.
    • Convenient new mat-specific modelling methods are added to automatically and rapidly create mats by clicking supported columns and/ or walls or grid intersections.
  • Piled Foundations - a new feature allows the definition and automated design of isolated pile caps and piles supporting a column. The size of the pile cap and/ or the number and layout of piles can be auto-designed as well as directly specified.
    • Pile caps and piles are included in automated Foundation Layout and Detail drawings, schedules and reinforcement quantities.

General & Modelling

  • User Defined Attributes (UDA’s) - a powerful new feature has now been added for UDA’s; selection groups are now automatically created and displayed in the Groups tab of the Project Workspace, enabling rapid editing of user-defined groups of any number and type of element.
  • Partial Base fixity - new options of “Nominally Pinned” and “Nominally Fixed” have now been added for column support fixities. For these settings a spring stiffness value - which is a percentage of the column’s stiffness - is automatically calculated and applied at the support. The stiffness percentage (10% for “Nominally Pinned” and 100% for “Nominally Fixed”) is displayed and can be edited.
  • 2D Views - the following features have been added to increase modelling convenience:
    • A new 2D/3D toggle button is added at the bottom RH corner of the active view.
    • Panels - a new option has been added to the right-click context menu to open the selected panel’s associated 2D view - Level, Frame or Inclined Plane - for all panels types.
  • Materials - Timber - for the EC & US headcodes new timber databases include Glulam sections and Structural Composite Lumber along with the associated timber grades.
  • Integration & BIM - the following new Integration options are added:
    • Bi-directional BIM Integration with Revit 2017.
    • Export to STAAD - saves geometry and loading to the .std file format.
  • Program Updates - a dedicated “Check for Updates” command is now added to the Home Ribbon to assist with ensuring the program is up to date.

Loading

  • Pattern Loading - this can now automatically be applied to steel beams, the feature working in the same manner as for concrete beams. A new tick-box setting to activate this feature is added to Home > Model Settings > Loading > “Use pattern loading for steel beams” (11905)
  • Polygon (Area) Load - an area load of a polygon shape with any number of vertices can now be created. In addition, the shape of the load can subsequently be graphically edited by selecting the load and moving any of its vertices to a new position.

Analysis & Results

  • Envelopes - display and output of results for Load Combination Envelopes is now enabled for the following:
    • Foundation Reactions (11289).
    • 2D Element Design Moments and Steel Areas for both contour diagrams and Result Strips.
    • 2D Wall Results.

Design

General

  • Wind Drift - a Wind Drift Limit ratio setting has been added to the properties of columns of all materials, both for all and individual stacks. The storey drift is automatically checked against a user-defined limit during the Design processes for each stack for each wind load case. A new Report for this has been added to Design Tabular Data view as has an associated Model Report item.
    • The shape of the column wind drift displacements can be viewed graphically in a similar manner to those for the column Sway checks; in the Results View using the Sway Drift and Storey Shear Ribbon group “X” and “Y” (direction) buttons when a Wind Load case is selected (12196).
  • Steel Design - Cold Formed - Design for Cold Formed Steel sections for the BS & EC head codes has been added.
  • Seismic Wizard - Response Spectrum Analysis (RSA) - Site Specific Spectra can now be defined for locations which use another country’s loading and design code, but where the spectra given in that code are not appropriate for the design location. An example is Thailand, where the Eurocode EC8 design code can be used, but where site specific spectra are required that are not defined in the code.
  • Gravity Design - a new option is added Home > Settings > Design Options > General > Gravity Design > “Fix column nodes horizontally” to automatically apply lateral translational fixed supports to column nodes for the Building Analysis performed during the Gravity Design processes. This is on by default.
    • This is useful for early design stage when lateral systems have not been established. The automatic lateral supports can remove unwanted lateral displacements that may prevent analysis solution and/ or produce unrealistic forces. The setting does not apply to the following; Analysis run as a separate process; Analyse All (Static); the Building Analysis performed during Design All (Static).
    • Note that the lateral supports are not applied to nodes that are in a rigid floor diaphragm.

Head Code EC

  • Composite Beams - design of composite beams using precast concrete plank slabs to EC3, EC4 and SCI P401 is now added. A database of Bison (UK) planks is included together with the facility to add user-defined plank data.

Head Code India

  • Concrete Shear Walls - Concrete walls subjected to seismic forces are designed automatically in accordance with IS 13920-1993 (2003)
    • If RSA analysis forces are present, reinforcement layers, vertical bars and shear reinforcement are automatically checked for the seismic condition.
    • Automated boundary checks include; end zones (based on limiting stress checks), axial forces (at boundary elements), reduction in gravity load whilst strength checks are considered.
  • Steel Design - Seismic Design - design to IS 13920:1993 has been added for all steel members (columns, beams and braces) forming part of a Seismic Force Resisting System.

Head Code Malaysia (Eurocode)

  • Seismic & Wind Loading - the Seismic Load Wizard and the Wind Load Wizard are now enabled for this head code.
    • The Seismic Load Wizard includes ground acceleration data for Peninsular, Sarawak & Sabah regions.
    • Note: Wind Load Wizard follows UK National Annex guidance (Malaysian National Annex is not yet available).

Head Code US

  • Steel Design - Seismic Design - design to AISC 341-05 and AISC 341-10 has been added for all steel members (columns, beams and braces) forming part of a Seismic Force Resisting System.

Reports & Drawings

  • Result Filters - Load Combination Envelopes have now been added to the Report Filters for the majority of appropriate report items, significantly increasing the power and flexibility of reporting options. Envelopes can similarly be used when producing Foundation Reaction and Beam End Forces Drawings by selecting the desired Envelope prior to producing the drawing.
    • An additional Drawing Settings option has been added to specify the output of either Combination Strength or Service factors results (11721, 12192).
  • Column Splice Loads - the following output options are added (10718, 11505, 11637, 12239):
    • Splice Loads Report - an automated report item has been added to produce a report for the forces at splice positions in steel columns in which splices are defined.
    • Column Splice Loads Drawing - a new drawing type for this is added to the Draw Ribbon. The tabular splice loads information is placed in text boxes at the top and bottom of each lift for each column that contains a column splice.

Enhancements & Fixes

General & Modelling

  • Performance Improvements:
    • The combined Analysis & Design process has been streamlined and optimised. RAM requirements for this process have been reduced by a factor of between 2 and 3. Gains in performance, while model-dependent, can be very significant.
    • The Concrete Slab Design and Punching check processes are now an order of magnitude faster.
    • As part of the optimisation, lateral load cases are no longer analysed during Design for Non-linear models (such as those containing Tension Only bracing). Should analysis of these cases be required, there is a new setting Design > Options > Analysis > “Solve lateral loadcases in isolation if non-linear analysis is required during design”. It is necessary to activate this setting for Non-linear models if the engineer chooses the Second Order Amp. forces method of analysis for Design.
  • Property Sets - for more on using this essential productivity feature within TSD please see the following Help topic: “User Guides > Basics of TSD > Properties & Property Sets”. The following enhancements have been made in this area:
    • Slabs - property sets can now be created for all types of slab, both via the right-click context menu from an existing slab item, and via the Properties Window Save button while in slab creation mode (12245).
    • The Manage Property Sets dialog now includes a window in which the properties of a selected set can be displayed for review.
    • A similarly enhanced dialog is displayed when applying property sets so that the engineer can easily distinguish between their sets (12611).
  • Composite Beams - after an auto-design, when the auto-layout setting for studs was still enabled, the tooltip (displayed when the cursor was over such a beam) displayed zero (0) rather than the number of studs applied to the beam. This also affected the following; Member 2D text display, Scene Content/ Plan display information and the General Arrangement Drawing. The correct number of studs is now displayed (11489, 11668).
  • Portal Frames - the software now draws the Portal Frame more correctly in the graphics view. Previously the dimension to the rafter/ column intersection was shown to be to the top of the column if dimensioned, now the dimension line is correctly drawn to the rafter/ column centre line intersection.
  • Steel Beams - Flange Restraint Settings - the top flange restraint setting was changed from fully restrained to unrestrained in the following circumstances:
    • Reversing a beam direction using the Edit > Reverse command (12111).
    • Making copies of a beam for the copied beams (12532).
    • Editing a beam’s geometry by moving one or both ends of the beam to another point (12687).
  • Move Command - rarely a program error could occur when moving a large selection of steel members (11844).
  • Concrete Walls - FE Walls - the wall mesh beam properties have been improved for the following scenarios:
    • Axial and minor axis stiffness properties have been increased to better model the lateral connectivity to the wall for the circumstance where a connecting member does not coincide with a node of the wall FE mesh. Previously this could produce unrealistically large lateral deflections and erroneous vibration modes (11745).
    • Major axis stiffness is now reduced to account for openings below a wall mesh beam.
    • Where the wall mesh beam lies in a floor diaphragm, its internal nodes are removed from the diaphragm. Where the opening produces a ‘lintel beam’ above an opening, this more closely reflects the expected stiffness of such a beam.
  • Review View - Show\ Alter State - the functions in the Show\ Alter State Ribbon group can now be exited in the usual manner via the keyboard Escape button or a double-right mouse click (12420).
  • Slabs - Slab Split Operation - occasionally splitting a slab caused some of the existing slab area to be deleted (12476).
  • Deleting:
    • When deleting a selection of multiple member types, analysis elements and steel joists are now grouped separately under the parent group "Members" together with the previously separately grouped types (3445).
    • Steel Trusses - a program error could occur when deleting trusses the chords of which supported a slab and were overlaid by a slab patch (12659).
  • Slab Meshing - where a beam end attached to point on a slab edge, the analysis model slab mesh nodes were not automatically connected to the beam end node, rendering the beam and slab unconnected. This issue only affected TSD 2016 SP2 v16.0.2.55 (12483).
  • Frames & Grid Lines - when assigning a User Name to a grid line for which a 2D Frame existed, or editing the name, the Frame’s name listed in the Structure Tree did not update to reflect this change until the model was Saved and re-opened (12704).
  • 2D Frame Views - the Scene Content On/Off toggles for Grid and Construction lines did not function correctly; both Grid and Construction lines were set On/Off by the Construction lines option only. This issue only occurred in 2D Frame views (12707).
  • Columns - Construction Levels - when a brace was connected to a column at a construction level this split the column into stacks at this level, potentially producing unwanted column stacks. The column is now only split when the level is set to be a Floor (12623).
  • Steel Beams - Creation - when connecting a new beam to a point along an existing beam, a new “From End” option is added to the F2 specific distance tooltip to allow the user to attach the beam at a defined distance from the end as well as the start of the beam (12137).
  • View Configurations:
    • Cutting Planes - active cutting planes are now saved with a View Configuration. This is reflected when a such a saved View Configuration is opened and in View items included in Reports with such a saved view configuration applied (12076).
    • The Results > Service Factors setting was not saved with a view configuration, thus a saved view only displayed results for the Strength factors. The Service / Strength Factor setting is now saved with the view configuration (12709).
    • When the Black Background option was set (Home > Settings > Scene > Colours ) and Views were printed or included in reports, the background colour remained white meaning any text was not visible. Such views are now correctly printed and displayed with a black background (12372).

Loading

  • Load Cases - Slab self-weight message warning “not to be used for precast planks” is removed. The message was carried over from Fastrak Building Designer where it was relevant - however Tekla Structural Designer allows the unit weight of planks to be defined directly and so it is no longer required (12166).
  • Area Loads:
    • Roof Panels - rarely, for a sloping roof panel with a re-entrant angle on an edge (a vertices with an interior angle greater than 180°) producing a cut-out of the panel shape, the load decomposition could ignore the area removed by the cut-out thereby applying a load larger than the actual panel area. This was flagged by an error in the load summary check where the total load on structure (due to load decomposition) was > the user applied load (11809).
    • 2D Floor View - when area loads were added in a 2D Floor View using a window operation, if concrete walls were enclosed within the window, the area loads would also be applied to these. Area loads are not now applied to walls in this circumstance (12266).
    • Slab Split and Join - when slabs were split or joined using these commands, area loads on the slabs were removed. In this circumstance the area loads are now retained and applied to the new slab items created by the operation (12413).
  • Variable Patch Loads - the new Polygon Area Load features have been extended to the variable patch load command. Variable patch loads can now be created with a polygon shape of any number of vertices and subsequently edited in the same manner as variable patch loads. As part of this enhancement the functionality of this feature has changed as follows;
    • The polygon shape and location is defined first by clicking the reference point followed by the required vertices points, double-clicking on the final point to enclose the shape.
    • The operation then continues with further clicks on three of the polygon vertices to set the positions of the patch load values 1 to 3 which define the distribution of load within the patch. After the first load position has been clicked and the cursor is moved over the next position, a graphical preview is displayed showing how the patch load will work (clicking of invalid positions is prevented). The operation is completed when the third load position is clicked.
  • Load Decomposition - the decomposition process has been improved to cope with more unusual/ complex geometries for which, rarely, load was not decomposed correctly to all members. Note that where this occurred the automatic Load Summary check feature of TSD flagged an error regarding unapplied load so the engineer was aware and could take steps to address this (12306).

Validation

  • Supports - A validation warning is now added for supports applied within the length of a column since, in most circumstances, it is expected this will be due to a modelling error the user will wish to correct (12456).
  • “A” and “V” Brace Patterns - new validation is added to check and warn if such a brace pattern which forms part of a Seismic Force Resisting System (SFRS) is not vertically released, such that it does not prop or support vertically the beam it connects to (3427).

Analysis & Results

  • Vibration Analysis - Graphical Mode Shapes - the scale of the mode shape diagrams has been increased to make modal displacements clearer for larger models (50678)
  • Buckling Analysis - For some modes, due to the scaling method, the modal displacements were indistinguishable from zero and hence could not be displayed graphically. Buckling mode shapes are now scaled to unity so such modes have non-zero modal displacements and will display correctly (51149).
  • Chasedown Analysis - Coinciding solver nodes could prevent completion of the chase down analysis. This rare circumstance is now checked for more thoroughly by validation, however the chasedown analysis processing routines have also been made more tolerant should this still occur (11971).
  • Loading Summary check - where supports were applied within the length of a column the loading summary check could show an error in the results for total loads for the chasedown analyses (12456).
  • 1st & 2nd Order Non-linear - rarely this form of analysis could produce large and erroneous axial forces for a column stack resulting from an error in the imposed load reduction calculations. The issue was generally clearly apparent from the shape and magnitude of the reduced axial load diagram for affected columns/ stacks in both the Global analysis and Load Analysis result views (10966, 11567).
  • FE Chasedown Analysis - 1D element results - rarely no 1D element results were available for combinations including Imposed load cases for which the “Live Load Reductions” setting was enabled (12358).
  • Overall Displacements - under the “Design” group in the Status tree the “Overall Displacement” results now include separate branches for Strength and Service (Factors) extreme displacement values (12487).
  • US Head Code - Steel Joists - the minor axis inertia section property of the analysis elements of steel joists was incorrectly much too small. This could cause buckling issues during 2nd Order Analysis which could prevent solution (12752).

 

Design

General

  • Slab Design:
    • Slabs can now be designed for RSA forces when they contribute to the lateral load resistance system.
    • Imposed Load Reductions can be considered in slab design and punching checks at transfer levels
    • Punching checks - Point Loads - it is now possible to edit the point load depth breadth and orientation values in the properties of existing checks (51414).
  • Performance - Steel Design - the following members are no longer designed for pattern load combinations (this potentially also gives more concise output): Pin-ended single span steel beams, Steel Joists, Trusses.
  • Right-click Context Menu - Design Member - for consistency, the “Design Member” option in the context menu displayed when a member is right-clicked on is now controlled by the member’s Autodesign On/Off property. Previously this option was enabled regardless of the setting for this property, which was inconsistent with other functionality.
    • Note that the default model setting (Design > Options > Auto design) for Steel members is to set Autodesign off after Design. Hence, by default, it is now necessary to set Autodesign On (either via the member’s properties or the Review View > Show\Alter > Auto\Check Design command) to re-enable the context menu option if Design has been run.
  • Review View - Auto\Check Design - new functionality is added to only set Auto-Design On or Off, while retaining the option to toggle between these. In addition, an option is added to similarly edit the auto-layout setting for composite beam studs.
  • Design Results - “Expand All” and “Collapse All” buttons have been added at the bottom of the Design Results dialog to facilitate viewing and navigation of the results (12482).
  • Concrete Walls -
    • Occasionally the design process could not identify bar locations for exceptionally short walls, preventing the design process completing. Walls sufficiently short to cause this issue are impractical, hence this was a rare occurrence, however design has been enhanced to cope with this circumstance (12700).
    • Where a slab vertical offset moved the top or bottom of a slab beyond wall panel ends, the slab was not detected as providing restraint to the wall at the slab’s level and thus a longer wall effective length was used in design checks. The restraint check is now refined to consider such a slab as restraining providing its top or bottom edge is within half the slab depth of the panel end, which is considered to be a reasonable assumption (12696).

Head Code BS

  • Portal Frames - rarely, following a design, a Portal Frame object would issue an error when selected and when the Check Member process was run on a rafter of the frame via the right-click context menu (12562).

Head Code EC

  • Slab Punching checks - Graphical Results - for edge columns the outer perimeter where shear reinforcement is not required was not correctly shown outside the second basic control perimeter (12404).
  • Steel Design - Slimflor Fabricated sections - in some circumstances the design process could fail producing process errors in the Progress Log and showing no details when Design was run for an individual beam (12521).

Head Code India

  • Pad and Strip Footing Design - design to IS1904 - 1986 (2006) and IS1080 - 1985 (2002) for these is now added.

Head Code US

  • Materials - Steel - User defined steel grade Design Strength properties were changed after a design run due to an incorrect conversion to metric units being applied (12526).
  • Drift & Seismic Drift checks - Tabular Data & Reports - the column Drift and Seismic Drift report tables now include additional columns giving the maximum drift values for each direction (12488).
  • Slab Design - for loose bars, the format of the “reinforcement provided” description in the design details summary is changed to be consistent with that of the slab reinforcement text displayed graphically on the model (Scene Content > Slab Items > reinforcement text). Previously, the former gave the bar diameter (preceded by the “#” symbol), while the latter displayed the bar number. Both now display the bar number (10950).

Reports & Drawings

  • Reports General
    • Report Settings - a new option has been added for each report item to start on a new page (12439).
    • Headings for certain items included in a report that did not actually exist in a model were still included in the report. Such headings are now removed from report output (3342).
  • Material List - trusses created in the 3D view without using the Freeform Truss function were not listed in the Material list. A new Material List Report Option “Truss Members” has now been added in order that such trusses can be included (12224).
  • Foundation Reactions:
    • The Chase down analyses have now been added to the Analysis Type filter for these report items (11359, 11626, 11913).
    • A “Settings” option has been included to enable the output of either Combination Strength or Service factors results.
    • Occasionally the column reference was omitted for some Supports listed in the Foundation Reactions report (10803).
  • Beam End Forces - options have now been added to report the forces for both ends of the beam (10895, 11151).
  • Foundation Reactions & Beam End Forces - now that Combination Envelope filters are enabled for these, the number of report items for them is much reduced.
  • Element Properties - report item now includes the element name for Analysis Elements in the section properties table (11106).
  • Analysis Diagrams > 1D > Deflections - the scale bar was included displaying zero values. This is no longer included (11706).
  • General Arrangement Drawing -
    • Details for composite beams now include the amount of transverse reinforcement applied to the beam. This information is also displayed graphically in the program as follows; via the tooltip when hovering the cursor over the a beam; in the Plan view when this is enable in the Scene Content; the 2D text for Members. (11962, 11995).
    • 2D Frames - rarely, for models which had been set out using predominantly construction lines rather than grid lines, the General Arrangement Drawing for some 2D Frames could not be created (12676)
  • Foundation Reactions Drawing - the settings (Draw > Edit > Options > Foundation Reactions > General) have been simplified and improved as follows:
    • The options under “Reaction Values” are removed now that Envelopes have been enabled for this output. The results shown on the drawing are now always controlled by the Load Case, Combination or Envelope currently selected for viewing in the program.
    • An option is added to output results for either Strength or Service Combination factors. If the drawing is generated while a Results view is active, the “Strength Factors” and “Service Factors” buttons in the Ribbon “Result Type” group take precedence (12435).
    • New user-controlled threshold values for Moment and Shear are added to remove smaller reaction values which the engineer wishes to omit from the drawing (12292).
  • Member Reports - output and options are enhanced as follows:
    • Design Calculations - the output for Design Calculations set to the “Critical” level (the default) have been improved; the output now includes the relevant 'level 1' summary calculations in addition to the critical combination name; only calculations marked as critical - indicated by the '!' symbol in Design Details - are output (12438, 12649).
    • Concrete Beams and Walls - items have been added to include both the Force-Moment and Moment-Moment Interaction Diagrams in the report (12441).
    • All Member types - a new Style option ‘Active Style’ is added which defaults to On. Model reports are then controlled by the “Active” Member Report style (set by opening Reports > Member Report > Member Type then selecting a style and clicking the “Active” button). The existing style options “…Design” and “…Summary” are also available, giving the flexibility of directly controlling the style, or using the Active one (12449).
    • For the default Result Type setting of '"Static & RSA", tables for RSA design results with an “Unknown” status were included when no RSA analysis and design had been performed. These tables are now automatically omitted in this circumstance (50382).
  • Slab Detailing:
    • Patch Reinforcement - a new option is added to control the anchorage length shown in these drawings for patch reinforcement; to draw either the full anchorage length or an indicative length controlled by user-defined parameters (3364).
    • Four new drawing layers and associated controls are added to separately control the output of slab panel and patch reinforcement. An option is also added to control the display of patches that do not add any reinforcement (11659).
  • Material List - Concrete Walls - an output column is added to the Material List table for walls giving the Gross surface area so the output is now equivalent to that given for slabs (3365).

Notes:

The number in brackets after an item denotes an internal reference number. This can be quoted to your local Support Department should further information on an item be required.

Content rating: 
Average page rating: 4 (24 votes)
Refresh page after voting to show updated result.